{"answers":{"affected":"2 open source packages ship an affected version, including com.cronutils:cron-utils. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41269 in the wild and no public exploit code.","fix":"Upgrade com.cronutils:cron-utils to 9.1.6 or later.","what":"CVE-2021-41269 is a critical code injection vulnerability in jmrozanec cron-utils, published on 15 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41269 and fix it if it is affected.\n\nWhat it is: CVE-2021-41269 is a critical code injection vulnerability in jmrozanec cron-utils, published on 15 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41269 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.cronutils:cron-utils (Maven): affected all versions; fixed in 9.1.6\n- com.cronutils:cron-utils (Maven): affected all versions; fixed in 9.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41269/ (Markdown: https://insights.sbomify.com/CVE-2021-41269/index.md)","id":"CVE-2021-41269","markdown":"https://insights.sbomify.com/CVE-2021-41269/index.md","name":"CVE-2021-41269","record":{"aliases":["GHSA-p9m8-27x8-rg87"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Java cron library","requires_auth":"none","summary":"Attackers can execute arbitrary code via Java EL injection in cron-utils when validating untrusted Cron expressions using the @Cron annotation.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"cron-utils","vendor":"cron-utils_project"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"cron-utils is a Java library to define, parse, validate, migrate crons as well as get human readable descriptions for them. In affected versions A template Injection was identified in cron-utils enabling attackers to inject arbitrary Java EL expressions, leading to unauthenticated Remote Code Execution (RCE) vulnerability. Versions up to 9.1.2 are susceptible to this vulnerability. Please note, that only projects using the @Cron annotation to validate untrusted Cron expressions are affected. The issue was patched and a new version was released. Please upgrade to version 9.1.6. There are no known workarounds known.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2025-08-20","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-08-20T11:51:40Z","kind":"github_poc","ref":"https://github.com/shoucheng3/jmrozanec__cron-utils_CVE-2021-41269_9-1-5","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Unauthenticated remote code injection in cron-utils","id":"CVE-2021-41269","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"CSV Injection in Symfony","id":"CVE-2021-41270"},"packages":[{"ecosystem":"Maven","fixed":["9.1.6"],"introduced":["0"],"last_affected":[],"package":"com.cronutils:cron-utils","purl":null,"source":"GHSA-p9m8-27x8-rg87"},{"ecosystem":"Maven","fixed":["9.1.6"],"introduced":["0"],"last_affected":[],"package":"com.cronutils:cron-utils","purl":"pkg:maven/com.cronutils/cron-utils","source":"GHSA-p9m8-27x8-rg87"}],"prev":{"headline":"Cookie persistence in Symfony","id":"CVE-2021-41268"},"products":["cron-utils"],"published":"2021-11-15","related":[{"cvss_score":7.9,"headline":"Critical vulnerability found in cron-utils","id":"CVE-2020-26238","kev_date_added":null,"published":"2020-11-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["jmrozanec"]},"summary":"Attackers can execute arbitrary code via Java EL injection in cron-utils when validating untrusted Cron expressions using the @Cron annotation.","url":"https://insights.sbomify.com/CVE-2021-41269/"}