# CVE-2021-41269: Unauthenticated remote code injection in cron-utils

> Attackers can execute arbitrary code via Java EL injection in cron-utils when validating untrusted Cron expressions using the @Cron annotation.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-p9m8-27x8-rg87

## What is CVE-2021-41269?

CVE-2021-41269 is a critical code injection vulnerability in jmrozanec cron-utils, published on 15 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

cron-utils is a Java library to define, parse, validate, migrate crons as well as get human readable descriptions for them. In affected versions A template Injection was identified in cron-utils enabling attackers to inject arbitrary Java EL expressions, leading to unauthenticated Remote Code Execution (RCE) vulnerability. Versions up to 9.1.2 are susceptible to this vulnerability. Please note, that only projects using the @Cron annotation to validate untrusted Cron expressions are affected. The issue was patched and a new version was released. Please upgrade to version 9.1.6. There are no known workarounds known.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2021-41269?

2 open source packages ship an affected version, including com.cronutils:cron-utils. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.cronutils:cron-utils` | Maven | All versions | 9.1.6 |
| `com.cronutils:cron-utils` | Maven | All versions | 9.1.6 |

Products: Cron-Utils Project Cron-Utils.

## How do I fix CVE-2021-41269?

Upgrade com.cronutils:cron-utils to 9.1.6 or later.

## Is CVE-2021-41269 being exploited?

There is no known exploitation of CVE-2021-41269 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/jmrozanec__cron-utils_CVE-2021-41269_9-1-5 (github_poc): https://github.com/shoucheng3/jmrozanec__cron-utils_CVE-2021-41269_9-1-5

## Other vulnerabilities in jmrozanec cron-utils

- [CVE-2020-26238](https://insights.sbomify.com/CVE-2020-26238/): Critical vulnerability found in cron-utils (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41269 and fix it if it is affected.

What it is: CVE-2021-41269 is a critical code injection vulnerability in jmrozanec cron-utils, published on 15 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41269 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.cronutils:cron-utils (Maven): affected all versions; fixed in 9.1.6
- com.cronutils:cron-utils (Maven): affected all versions; fixed in 9.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41269/ (Markdown: https://insights.sbomify.com/CVE-2021-41269/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41269
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41269
- OSV: https://osv.dev/vulnerability/CVE-2021-41269

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41269/
Summaries are generated and may contain mistakes; the official description above is the record.
