# CVE-2021-41273: Cross-Site Request Forgery allowing sending of test emails and generation of node auto-deployment keys

> Attackers can force administrative users to send test emails or generate unexpected auto-deployment tokens via CSRF in Pterodactyl panel.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-wwgq-9jhf-qgw6

## What is CVE-2021-41273?

CVE-2021-41273 is a medium-severity vulnerability in pterodactyl panel, published on 17 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Pterodactyl is an open-source game server management panel built with PHP 7, React, and Go. Due to improperly configured CSRF protections on two routes, a malicious user could execute a CSRF-based attack against the following endpoints: Sending a test email and Generating a node auto-deployment token. At no point would any data be exposed to the malicious user, this would simply trigger email spam to an administrative user, or generate a single auto-deployment token unexpectedly. This token is not revealed to the malicious user, it is simply created unexpectedly in the system. This has been addressed in release `1.6.6`. Users may optionally manually apply the fixes released in v1.6.6 to patch their own systems.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2021-41273?

2 open source packages ship an affected version, including pterodactyl/panel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pterodactyl/panel` | Packagist | All versions | 1.6.6 |
| `pterodactyl/panel` | Packagist | All versions | 1.6.6 |

Products: Pterodactyl Panel.

## How do I fix CVE-2021-41273?

Upgrade pterodactyl/panel to 1.6.6 or later.

## Is CVE-2021-41273 being exploited?

There is no known exploitation of CVE-2021-41273 in the wild and no public exploit code.

## Other vulnerabilities in pterodactyl panel

- [CVE-2026-26016](https://insights.sbomify.com/CVE-2026-26016/): Pterodactyl Panel Allows Cross-Node Server Configuration Disclosure via Remote API Missing Authorization (critical 9.2)
- [CVE-2021-41129](https://insights.sbomify.com/CVE-2021-41129/): Authentication bypass in Pterodactyl (high 8.1)
- [CVE-2025-68954](https://insights.sbomify.com/CVE-2025-68954/): Pterodactyl does not revoke SFTP access when server is deleted or permissions reduced (high 7.5)
- [CVE-2019-1020002](https://insights.sbomify.com/CVE-2019-1020002/): Pterodactyl vulnerable to 2FA Sniffing (high 7.5)
- [CVE-2025-69197](https://insights.sbomify.com/CVE-2025-69197/): Pterodactyl TOTPs can be reused during validity window (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41273 and fix it if it is affected.

What it is: CVE-2021-41273 is a medium-severity vulnerability in pterodactyl panel, published on 17 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-41273 in the wild and no public exploit code.

Affected packages and fixed versions:
- pterodactyl/panel (Packagist): affected all versions; fixed in 1.6.6
- pterodactyl/panel (Packagist): affected all versions; fixed in 1.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41273/ (Markdown: https://insights.sbomify.com/CVE-2021-41273/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41273
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41273
- OSV: https://osv.dev/vulnerability/CVE-2021-41273

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41273/
Summaries are generated and may contain mistakes; the official description above is the record.
