{"answers":{"affected":"2 open source packages ship an affected version, including solidus_auth_devise. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41274 in the wild and no public exploit code.","fix":"Upgrade solidus_auth_devise to 2.5.4 or later.","what":"CVE-2021-41274 is a critical vulnerability in solidusio solidus_auth_devise, published on 17 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-41274 and fix it if it is affected.\n\nWhat it is: CVE-2021-41274 is a critical vulnerability in solidusio solidus_auth_devise, published on 17 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-41274 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- solidus_auth_devise (RubyGems): affected from 1.0.0; fixed in 2.5.4\n- solidus_auth_devise (RubyGems): affected from 1.0.0; fixed in 2.5.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41274/ (Markdown: https://insights.sbomify.com/CVE-2021-41274/index.md)","id":"CVE-2021-41274","markdown":"https://insights.sbomify.com/CVE-2021-41274/index.md","name":"CVE-2021-41274","record":{"aliases":["GHSA-xm34-v85h-9pg2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Solidus authentication gem","requires_auth":"none","summary":"A CSRF vulnerability in solidus_auth_devise allows attackers to take over user accounts if specific Rails forgery protection settings are used.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"solidus_auth_devise","vendor":"nebulab"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"solidus_auth_devise provides authentication services for the Solidus webstore framework, using the Devise gem. In affected versions solidus_auth_devise is subject to a CSRF vulnerability that allows user account takeover. All applications using any version of the frontend component of `solidus_auth_devise` are affected if `protect_from_forgery` method is both: Executed whether as: A `before_action` callback (the default) or A `prepend_before_action` (option `prepend: true` given) before the `:load_object` hook in `Spree::UserController` (most likely order to find). Configured to use `:null_session` or `:reset_session` strategies (`:null_session` is the default in case the no strategy is given, but `rails --new` generated skeleton use `:exception`). Users should promptly update to `solidus_auth_devise` version `2.5.4`. Users unable to update should if possible, change their strategy to `:exception`. Please see the linked GHSA for more workaround details.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authentication Bypass by CSRF Weakness","id":"CVE-2021-41274","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"csrf","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Authentication Bypass by CSRF Weakness","id":"CVE-2021-41275"},"packages":[{"ecosystem":"RubyGems","fixed":["2.5.4"],"introduced":["1.0.0"],"last_affected":[],"package":"solidus_auth_devise","purl":null,"source":"GHSA-xm34-v85h-9pg2"},{"ecosystem":"RubyGems","fixed":["2.5.4"],"introduced":["1.0.0"],"last_affected":[],"package":"solidus_auth_devise","purl":"pkg:gem/solidus_auth_devise","source":"GHSA-xm34-v85h-9pg2"}],"prev":{"headline":"Cross-Site Request Forgery allowing sending of test emails and generation of node auto-deployment keys","id":"CVE-2021-41273"},"products":["solidus_auth_devise"],"published":"2021-11-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["solidusio"]},"summary":"A CSRF vulnerability in solidus_auth_devise allows attackers to take over user accounts if specific Rails forgery protection settings are used.","url":"https://insights.sbomify.com/CVE-2021-41274/"}