# CVE-2021-41281: Path traversal in Matrix Synapse

> Attackers can trick Matrix Synapse into downloading remote files to arbitrary directories if the media repository is enabled, requiring an upgrade to fix.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-3hfw-x7gx-437c, PYSEC-2021-436, UBUNTU-CVE-2021-41281, openSUSE-SU-2024:11649-1

## What is CVE-2021-41281?

CVE-2021-41281 is a high-severity path traversal vulnerability in Fedoraproject Fedora, published on 23 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Synapse is a package for Matrix homeservers written in Python 3/Twisted. Prior to version 1.47.1, Synapse instances with the media repository enabled can be tricked into downloading a file from a remote server into an arbitrary directory. No authentication is required for the affected endpoint. The last 2 directories and file name of the path are chosen randomly by Synapse and cannot be controlled by an attacker, which limits the impact. Homeservers with the media repository disabled are unaffected. Homeservers with a federation whitelist are also unaffected, since Synapse will check the remote hostname, including the trailing `../`s, against the whitelist. Server administrators should upgrade to 1.47.1 or later. Server administrators using a reverse proxy could, at the expense of losing media functionality, may block the certain endpoints as a workaround. Alternatively, non-containerized deployments can be adapted to use the hardened systemd config.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-41281?

3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.47.1 |
| `matrix-synapse` | PyPI | All versions | 1.47.1 |
| `matrix-synapse` | PyPI | All versions | 1.47.1 |
| `matrix-synapse` | openSUSE:Tumbleweed | All versions | 1.47.1-1.1 |

Products: Fedoraproject Fedora, Matrix Synapse.

## How do I fix CVE-2021-41281?

Upgrade matrix-synapse to 1.47.1 or later.

## Is CVE-2021-41281 being exploited?

There is no known exploitation of CVE-2021-41281 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41281 and fix it if it is affected.

What it is: CVE-2021-41281 is a high-severity path traversal vulnerability in Fedoraproject Fedora, published on 23 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41281 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.47.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.47.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.47.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41281/ (Markdown: https://insights.sbomify.com/CVE-2021-41281/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41281
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41281
- OSV: https://osv.dev/vulnerability/CVE-2021-41281

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41281/
Summaries are generated and may contain mistakes; the official description above is the record.
