# CVE-2021-4132: Cross-site Scripting (XSS) - Stored in livehelperchat/livehelperchat

> Attackers can inject malicious scripts into Live Helper Chat, potentially stealing user sessions or executing code in victim browsers.

- **Severity:** High 7.3 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-livehelperchat-2021-4132, GHSA-f7xw-46vh-5jw2

## What is CVE-2021-4132?

CVE-2021-4132 is a high-severity cross-site scripting vulnerability in livehelperchat/livehelperchat, published on 17 Dec 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

livehelperchat is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-4132?

3 open source packages ship an affected version, including remdex/livehelperchat and livehelperchat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `remdex/livehelperchat` | Packagist | All versions | 3.91 |
| `remdex/livehelperchat` | Packagist | All versions | 3.91 |
| `livehelperchat` | Bitnami | All versions | 3.90.0 |

Products: Livehelperchat Live Helper Chat.

## How do I fix CVE-2021-4132?

Upgrade remdex/livehelperchat to 3.91 or later.

## Is CVE-2021-4132 being exploited?

There is no known exploitation of CVE-2021-4132 in the wild and no public exploit code.

## Other vulnerabilities in livehelperchat/livehelperchat

- [CVE-2024-27516](https://insights.sbomify.com/CVE-2024-27516/): livehelperchat Server-Side Template Injection (critical 9.8)
- [CVE-2022-0935](https://insights.sbomify.com/CVE-2022-0935/): Host Header injection in password Reset in livehelperchat/livehelperchat (high 8.8)
- [CVE-2022-1234](https://insights.sbomify.com/CVE-2022-1234/): XSS in livehelperchat in livehelperchat/livehelperchat (high 8.8)
- [CVE-2022-1191](https://insights.sbomify.com/CVE-2022-1191/): SSRF on index.php/cobrowse/proxycss/ in livehelperchat/livehelperchat (high 8.7)
- [CVE-2022-1213](https://insights.sbomify.com/CVE-2022-1213/): SSRF filter bypass port 80, 433 in livehelperchat/livehelperchat (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4132 and fix it if it is affected.

What it is: CVE-2021-4132 is a high-severity cross-site scripting vulnerability in livehelperchat/livehelperchat, published on 17 Dec 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-4132 in the wild and no public exploit code.

Affected packages and fixed versions:
- remdex/livehelperchat (Packagist): affected all versions; fixed in 3.91
- remdex/livehelperchat (Packagist): affected all versions; fixed in 3.91
- livehelperchat (Bitnami): affected all versions; fixed in 3.90.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4132/ (Markdown: https://insights.sbomify.com/CVE-2021-4132/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4132
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4132
- OSV: https://osv.dev/vulnerability/CVE-2021-4132

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4132/
Summaries are generated and may contain mistakes; the official description above is the record.
