# CVE-2021-41411: XML External Entity Reference in drools

> An attacker can exploit an XML External Entity vulnerability in the Drools rules engine to read sensitive files or cause denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jun 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-rc57-9r3x-98cq

## What is CVE-2021-41411?

CVE-2021-41411 is a critical vulnerability in n/a, published on 16 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

drools <=7.59.x is affected by an XML External Entity (XXE) vulnerability in KieModuleMarshaller.java. The Validator class is not used correctly, resulting in the XXE injection vulnerability.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2021-41411?

2 open source packages ship an affected version, including org.drools:drools-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.drools:drools-core` | Maven | All versions | 7.60.0.Final |
| `org.drools:drools-core` | Maven | All versions | 7.60.0.Final |

Products: Redhat Drools.

## How do I fix CVE-2021-41411?

Upgrade org.drools:drools-core to 7.60.0.Final or later.

## Is CVE-2021-41411 being exploited?

There is no known exploitation of CVE-2021-41411 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-8125](https://insights.sbomify.com/CVE-2014-8125/): Improper Input Validation in Drools and jBPM (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41411 and fix it if it is affected.

What it is: CVE-2021-41411 is a critical vulnerability in n/a, published on 16 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41411 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.drools:drools-core (Maven): affected all versions; fixed in 7.60.0.Final
- org.drools:drools-core (Maven): affected all versions; fixed in 7.60.0.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41411/ (Markdown: https://insights.sbomify.com/CVE-2021-41411/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41411
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41411
- OSV: https://osv.dev/vulnerability/CVE-2021-41411

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41411/
Summaries are generated and may contain mistakes; the official description above is the record.
