{"answers":{"affected":"3 open source packages ship an affected version, including pyo. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41499 in the wild and no public exploit code.","fix":"Upgrade pyo to 1.0.3 or later.","what":"CVE-2021-41499 is a high-severity denial of service vulnerability in n/a, published on 17 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41499 and fix it if it is affected.\n\nWhat it is: CVE-2021-41499 is a high-severity denial of service vulnerability in n/a, published on 17 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41499 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pyo (PyPI): affected all versions; fixed in 1.0.3\n- pyo (PyPI): affected all versions; fixed in 1.0.3\n- pyo (PyPI): affected all versions; fixed in 1.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41499/ (Markdown: https://insights.sbomify.com/CVE-2021-41499/index.md)","id":"CVE-2021-41499","markdown":"https://insights.sbomify.com/CVE-2021-41499/index.md","name":"CVE-2021-41499","record":{"aliases":["DEBIAN-CVE-2021-41499","GHSA-5f5c-687x-g5qm","PYSEC-2026-743","UBUNTU-CVE-2021-41499"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Pyo audio library","requires_auth":"none","summary":"Remote attackers can cause a denial of service in the Pyo audio library by passing an overlong audio file name to the Server_debug function.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pyo","vendor":"pyo_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"}],"description":"Buffer Overflow Vulnerability exists in ajaxsoundstudio.com n Pyo \u003c 1.03 in the Server_debug function, which allows remote attackers to conduct DoS attacks by deliberately passing on an overlong audio file name.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Classic Buffer Overflow in pyo","id":"CVE-2021-41499","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":3,"n_references":1,"next":{"headline":"Incorrect Comparison in cvxopt","id":"CVE-2021-41500"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.3"],"introduced":["0"],"last_affected":[],"package":"pyo","purl":null,"source":"GHSA-5f5c-687x-g5qm"},{"ecosystem":"PyPI","fixed":["1.0.3"],"introduced":["0"],"last_affected":[],"package":"pyo","purl":"pkg:pypi/pyo","source":"GHSA-5f5c-687x-g5qm"},{"ecosystem":"PyPI","fixed":["1.0.3"],"introduced":["0"],"last_affected":[],"package":"pyo","purl":"pkg:pypi/pyo","source":"PYSEC-2026-743"}],"prev":{"headline":"Pyo Buffer Overflow Vulnerability","id":"CVE-2021-41498"},"products":["n/a"],"published":"2021-12-17","related":[{"cvss_score":7.5,"headline":"Pyo Buffer Overflow Vulnerability","id":"CVE-2021-41498","kev_date_added":null,"published":"2021-12-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service in the Pyo audio library by passing an overlong audio file name to the Server_debug function.","url":"https://insights.sbomify.com/CVE-2021-41499/"}