# CVE-2021-41499: Classic Buffer Overflow in pyo

> Remote attackers can cause a denial of service in the Pyo audio library by passing an overlong audio file name to the Server_debug function.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-41499, GHSA-5f5c-687x-g5qm, PYSEC-2026-743, UBUNTU-CVE-2021-41499

## What is CVE-2021-41499?

CVE-2021-41499 is a high-severity denial of service vulnerability in n/a, published on 17 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Buffer Overflow Vulnerability exists in ajaxsoundstudio.com n Pyo < 1.03 in the Server_debug function, which allows remote attackers to conduct DoS attacks by deliberately passing on an overlong audio file name.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2021-41499?

3 open source packages ship an affected version, including pyo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyo` | PyPI | All versions | 1.0.3 |
| `pyo` | PyPI | All versions | 1.0.3 |
| `pyo` | PyPI | All versions | 1.0.3 |

Products: Pyo Project Pyo.

## How do I fix CVE-2021-41499?

Upgrade pyo to 1.0.3 or later.

## Is CVE-2021-41499 being exploited?

There is no known exploitation of CVE-2021-41499 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-41498](https://insights.sbomify.com/CVE-2021-41498/): Pyo Buffer Overflow Vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41499 and fix it if it is affected.

What it is: CVE-2021-41499 is a high-severity denial of service vulnerability in n/a, published on 17 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41499 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyo (PyPI): affected all versions; fixed in 1.0.3
- pyo (PyPI): affected all versions; fixed in 1.0.3
- pyo (PyPI): affected all versions; fixed in 1.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41499/ (Markdown: https://insights.sbomify.com/CVE-2021-41499/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41499
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41499
- OSV: https://osv.dev/vulnerability/CVE-2021-41499

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41499/
Summaries are generated and may contain mistakes; the official description above is the record.
