# CVE-2021-41524: null pointer dereference in h2 fuzzing

> An external attacker can cause a denial of service in Apache HTTP Server by sending a specially crafted HTTP/2 request that triggers a null pointer dereference.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2021-41524, BIT-apache-2021-41524, CLEANSTART-2026-EB87524, DEBIAN-CVE-2021-41524, GHSA-f29c-hjcq-ww2f

## What is CVE-2021-41524?

CVE-2021-41524 is a high-severity vulnerability in Apache Http Server, published on 5 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

While fuzzing the 2.4.49 httpd, a new null pointer dereference was detected during HTTP/2 request processing, allowing an external source to DoS the server. This requires a specially crafted request. The vulnerability was recently introduced in version 2.4.49. No exploit is known to the project.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2021-41524?

1 open source package ship an affected version, including apache. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.49 | 2.4.50 |

Products: Apache Http Server, Fedoraproject Fedora, Netapp Cloud Backup, Oracle Instantis Enterprisetrack.

## How do I fix CVE-2021-41524?

Upgrade apache to 2.4.50 or later.

## Is CVE-2021-41524 being exploited?

There is no known exploitation of CVE-2021-41524 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41524 and fix it if it is affected.

What it is: CVE-2021-41524 is a high-severity vulnerability in Apache Http Server, published on 5 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41524 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.49; fixed in 2.4.50

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41524/ (Markdown: https://insights.sbomify.com/CVE-2021-41524/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41524
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41524
- OSV: https://osv.dev/vulnerability/CVE-2021-41524

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41524/
Summaries are generated and may contain mistakes; the official description above is the record.
