{"answers":{"affected":"It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-41556 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2021-41556 is a critical memory corruption vulnerability in Fedoraproject Fedora, published on 28 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41556 and fix it if it is affected.\n\nWhat it is: CVE-2021-41556 is a critical memory corruption vulnerability in Fedoraproject Fedora, published on 28 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-41556 exists.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41556/ (Markdown: https://insights.sbomify.com/CVE-2021-41556/index.md)","id":"CVE-2021-41556","markdown":"https://insights.sbomify.com/CVE-2021-41556/index.md","name":"CVE-2021-41556","record":{"aliases":["DEBIAN-CVE-2021-41556","GHSA-cm28-mc8h-9h49","MGASA-2023-0150","UBUNTU-CVE-2021-41556","openSUSE-SU-2023:0080-1","openSUSE-SU-2024:12611-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Squirrel scripting engine","requires_auth":"none","summary":"An out-of-bounds read in the Squirrel interpreter allows attackers to execute arbitrary code and escape the sandbox by providing a malicious script.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"squirrel","vendor":"squirrel-lang"}],"cvss":{"score":10,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"sqclass.cpp in Squirrel through 2.2.5 and 3.x through 3.1 allows an out-of-bounds read (in the core interpreter) that can lead to Code Execution. If a victim executes an attacker-controlled squirrel script, it is possible for the attacker to break out of the squirrel script sandbox even if all dangerous functionality such as File System functions has been disabled. An attacker might abuse this bug to target (for example) Cloud services that allow customization via SquirrelScripts, or distribute malware through video games that embed a Squirrel Engine.","ecosystems":["SUSE:Package Hub 15 SP4","openSUSE:Leap 15.4","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2021-41556","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"memory_corruption","year":"2021"},"n_packages":3,"n_references":5,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2021-41557"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP4","fixed":["3.0.7-bp154.3.3.1"],"introduced":["0"],"last_affected":[],"package":"squirrel","purl":"pkg:rpm/suse/squirrel\u0026distro=SUSE%20Package%20Hub%2015%20SP4","source":"openSUSE-SU-2023:0080-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["3.0.7-bp154.3.3.1"],"introduced":["0"],"last_affected":[],"package":"squirrel","purl":"pkg:rpm/opensuse/squirrel\u0026distro=openSUSE%20Leap%2015.4","source":"openSUSE-SU-2023:0080-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.2-1.1"],"introduced":["0"],"last_affected":[],"package":"squirrel","purl":"pkg:rpm/opensuse/squirrel\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12611-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2021-41555"},"products":["n/a"],"published":"2022-07-28","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-29","vendors":["n/a"]},"summary":"An out-of-bounds read in the Squirrel interpreter allows attackers to execute arbitrary code and escape the sandbox by providing a malicious script.","url":"https://insights.sbomify.com/CVE-2021-41556/"}