CVE-2021-41561 Apache Parquet-MR potential DoS in case of malicious Parquet file
Attackers can cause denial of service in applications using Apache Parquet-MR by providing malicious Parquet files due to improper input validation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-41561?
CVE-2021-41561 is a high-severity denial of service vulnerability in Apache Parquet, published on 20 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Input Validation vulnerability in Parquet-MR of Apache Parquet allows an attacker to DoS by malicious Parquet files. This issue affects Apache Parquet-MR version 1.9.0 and later versions.
Weakness: CWE-20
Which versions are affected by CVE-2021-41561?
4 open source packages ship an affected version, including org.apache.parquet:parquet. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.parquet:parquet Maven | All versions | 1.11.2 |
org.apache.parquet:parquet Maven | All versions | 1.11.2 |
org.apache.parquet:parquet Maven | From 1.12.0 | 1.12.2 |
org.apache.parquet:parquet Maven | From 1.12.0 | 1.12.2 |
Products include Apache Parquet Java.
How do I fix CVE-2021-41561?
Upgrade org.apache.parquet:parquet to a fixed version for your release line: 1.11.2 or 1.12.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-41561 being exploited?
There is no known exploitation of CVE-2021-41561 in the wild and no public exploit code.
Other vulnerabilities in Apache Parquet
Sources
Also known as GHSA-gc67-crq6-hgh5.