# CVE-2021-41561: Apache Parquet-MR potential DoS in case of malicious Parquet file

> Attackers can cause denial of service in applications using Apache Parquet-MR by providing malicious Parquet files due to improper input validation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-gc67-crq6-hgh5

## What is CVE-2021-41561?

CVE-2021-41561 is a high-severity denial of service vulnerability in Apache Parquet, published on 20 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Parquet-MR of Apache Parquet allows an attacker to DoS by malicious Parquet files. This issue affects Apache Parquet-MR version 1.9.0 and later versions.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-41561?

4 open source packages ship an affected version, including org.apache.parquet:parquet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.parquet:parquet` | Maven | All versions | 1.11.2 |
| `org.apache.parquet:parquet` | Maven | All versions | 1.11.2 |
| `org.apache.parquet:parquet` | Maven | From 1.12.0 | 1.12.2 |
| `org.apache.parquet:parquet` | Maven | From 1.12.0 | 1.12.2 |

Products: Apache Parquet Java.

## How do I fix CVE-2021-41561?

Upgrade org.apache.parquet:parquet to a fixed version for your release line: 1.11.2 or 1.12.2.

## Is CVE-2021-41561 being exploited?

There is no known exploitation of CVE-2021-41561 in the wild and no public exploit code.

## Other vulnerabilities in Apache Parquet

- [CVE-2025-30065](https://insights.sbomify.com/CVE-2025-30065/): Apache Parquet Avro Module Vulnerable to Arbitrary Code Execution (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41561 and fix it if it is affected.

What it is: CVE-2021-41561 is a high-severity denial of service vulnerability in Apache Parquet, published on 20 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41561 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.parquet:parquet (Maven): affected all versions; fixed in 1.11.2
- org.apache.parquet:parquet (Maven): affected all versions; fixed in 1.11.2
- org.apache.parquet:parquet (Maven): affected from 1.12.0; fixed in 1.12.2
- org.apache.parquet:parquet (Maven): affected from 1.12.0; fixed in 1.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41561/ (Markdown: https://insights.sbomify.com/CVE-2021-41561/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41561
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41561
- OSV: https://osv.dev/vulnerability/CVE-2021-41561

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41561/
Summaries are generated and may contain mistakes; the official description above is the record.
