{"answers":{"affected":"2 open source packages ship an affected version, including passport-oauth2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41580 in the wild and no public exploit code.","fix":"Upgrade passport-oauth2 to 1.6.1 or later.","what":"CVE-2021-41580 is a medium-severity authentication bypass vulnerability in n/a, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41580 and fix it if it is affected.\n\nWhat it is: CVE-2021-41580 is a medium-severity authentication bypass vulnerability in n/a, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41580 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- passport-oauth2 (npm): affected all versions; fixed in 1.6.1\n- passport-oauth2 (npm): affected all versions; fixed in 1.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41580/ (Markdown: https://insights.sbomify.com/CVE-2021-41580/index.md)","id":"CVE-2021-41580","markdown":"https://insights.sbomify.com/CVE-2021-41580/index.md","name":"CVE-2021-41580","record":{"aliases":["GHSA-f794-r6xc-hf3v"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js OAuth library","requires_auth":"none","summary":"Attackers can bypass authentication if the OAuth provider returns HTTP 200 on failure and the application trusts the token without validation.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"passport-oauth2","vendor":"passportjs"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[],"description":"The passport-oauth2 package before 1.6.1 for Node.js mishandles the error condition of failure to obtain an access token. This is exploitable in certain use cases where an OAuth identity provider uses an HTTP 200 status code for authentication-failure error reports, and an application grants authorization upon simply receiving the access token (i.e., does not try to use the token). NOTE: the passport-oauth2 vendor does not consider this a passport-oauth2 vulnerability","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Access Control in passport-oauth2","id":"CVE-2021-41580","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2021-41581"},"packages":[{"ecosystem":"npm","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"passport-oauth2","purl":null,"source":"GHSA-f794-r6xc-hf3v"},{"ecosystem":"npm","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"passport-oauth2","purl":"pkg:npm/passport-oauth2","source":"GHSA-f794-r6xc-hf3v"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2021-41579"},"products":["n/a"],"published":"2021-09-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can bypass authentication if the OAuth provider returns HTTP 200 on failure and the application trusts the token without validation.","url":"https://insights.sbomify.com/CVE-2021-41580/"}