# CVE-2021-41580: Improper Access Control in passport-oauth2

> Attackers can bypass authentication if the OAuth provider returns HTTP 200 on failure and the application trusts the token without validation.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-f794-r6xc-hf3v

## What is CVE-2021-41580?

CVE-2021-41580 is a medium-severity authentication bypass vulnerability in n/a, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The passport-oauth2 package before 1.6.1 for Node.js mishandles the error condition of failure to obtain an access token. This is exploitable in certain use cases where an OAuth identity provider uses an HTTP 200 status code for authentication-failure error reports, and an application grants authorization upon simply receiving the access token (i.e., does not try to use the token). NOTE: the passport-oauth2 vendor does not consider this a passport-oauth2 vulnerability

## Which versions are affected by CVE-2021-41580?

2 open source packages ship an affected version, including passport-oauth2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passport-oauth2` | npm | All versions | 1.6.1 |
| `passport-oauth2` | npm | All versions | 1.6.1 |

Products: Passportjs Passport-Oauth2.

## How do I fix CVE-2021-41580?

Upgrade passport-oauth2 to 1.6.1 or later.

## Is CVE-2021-41580 being exploited?

There is no known exploitation of CVE-2021-41580 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41580 and fix it if it is affected.

What it is: CVE-2021-41580 is a medium-severity authentication bypass vulnerability in n/a, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41580 in the wild and no public exploit code.

Affected packages and fixed versions:
- passport-oauth2 (npm): affected all versions; fixed in 1.6.1
- passport-oauth2 (npm): affected all versions; fixed in 1.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41580/ (Markdown: https://insights.sbomify.com/CVE-2021-41580/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41580
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41580
- OSV: https://osv.dev/vulnerability/CVE-2021-41580

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41580/
Summaries are generated and may contain mistakes; the official description above is the record.
