# CVE-2021-41584: Information disclosure in n/a

> Attackers can view sensitive build and configuration details by sending a crafted HTTP request with a specific header.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-gradle-2021-41584, GHSA-pwr9-qwxg-647h

## What is CVE-2021-41584?

CVE-2021-41584 is a high-severity vulnerability in n/a, published on 24 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gradle Enterprise before 2021.1.3 can allow unauthorized viewing of a response (information disclosure of possibly sensitive build/configuration details) via a crafted HTTP request with the X-Gradle-Enterprise-Ajax-Request header.

## Which versions are affected by CVE-2021-41584?

1 open source package ship an affected version, including gradle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradle` | Bitnami | From 2020.4.0 | 2021.1.3 |

Products: Gradle Gradle.

## How do I fix CVE-2021-41584?

Upgrade gradle to 2021.1.3 or later.

## Is CVE-2021-41584 being exploited?

There is no known exploitation of CVE-2021-41584 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-15052](https://insights.sbomify.com/CVE-2019-15052/): Information disclosure in n/a (critical 9.8)
- [CVE-2016-6199](https://insights.sbomify.com/CVE-2016-6199/): Deserialization in n/a (critical 9.8)
- [CVE-2021-29428](https://insights.sbomify.com/CVE-2021-29428/): Local privilege escalation through system temporary directory (high 8.8)
- [CVE-2026-22816](https://insights.sbomify.com/CVE-2026-22816/): Gradle fails to disable repositories which can expose builds to malicious artifacts (high 8.6)
- [CVE-2026-22865](https://insights.sbomify.com/CVE-2026-22865/): Gradle's failure to disable repositories failing to answer can expose builds to malicious artifacts (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41584 and fix it if it is affected.

What it is: CVE-2021-41584 is a high-severity vulnerability in n/a, published on 24 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41584 in the wild and no public exploit code.

Affected packages and fixed versions:
- gradle (Bitnami): affected from 2020.4.0; fixed in 2021.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41584/ (Markdown: https://insights.sbomify.com/CVE-2021-41584/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41584
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41584
- OSV: https://osv.dev/vulnerability/CVE-2021-41584

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41584/
Summaries are generated and may contain mistakes; the official description above is the record.
