CVE-2021-41597 Cross-site request forgery in n/a
Attackers can achieve remote code execution in SuiteCRM via CSRF in the UpgradeWizard if a PHP file is included in a ZIP archive.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-41597?
CVE-2021-41597 is a high-severity vulnerability in Salesagility Suitecrm, published on 12 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
SuiteCRM through 7.11.21 is vulnerable to CSRF, with resultant remote code execution, via the UpgradeWizard functionality, if a PHP file is included in a ZIP archive.
Weakness: CWE-352
Which versions are affected by CVE-2021-41597?
1 open source package ship an affected version, including suitecrm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
suitecrm Bitnami | From 7.10.0 | 7.10.35, 7.12.2 |
Products include Salesagility Suitecrm.
How do I fix CVE-2021-41597?
Upgrade suitecrm to a fixed version for your release line: 7.10.35 or 7.12.2.
Is CVE-2021-41597 being exploited?
There is no known exploitation of CVE-2021-41597 in the wild and no public exploit code.
Other vulnerabilities in Salesagility Suitecrm
Sources
Also known as BIT-suitecrm-2021-41597, GHSA-38m6-xrq9-23c3.