# CVE-2021-41767: Private tunnel identifier may be included in the non-private details of active connections

> Authenticated users can read private tunnel identifiers to access other users' active connections, compromising session isolation in Apache Guacamole.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jan 2022
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-guacamole-2021-41767, BIT-guacamole-server-2021-41767, GHSA-8jvg-8759-x9j6, UBUNTU-CVE-2021-41767

## What is CVE-2021-41767?

CVE-2021-41767 is a medium-severity vulnerability in Apache Guacamole, published on 11 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Guacamole 1.3.0 and older may incorrectly include a private tunnel identifier in the non-private details of some REST responses. This may allow an authenticated user who already has permission to access a particular connection to read from or interact with another user's active use of that same connection.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-41767?

2 open source packages ship an affected version, including guacamole and guacamole-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guacamole` | Bitnami | All versions | 1.3.0 |
| `guacamole-server` | Bitnami | All versions | 1.3.0 |

Products: Apache Guacamole.

## How do I fix CVE-2021-41767?

Upgrade guacamole to 1.3.0 or later.

## Is CVE-2021-41767 being exploited?

There is no known exploitation of CVE-2021-41767 in the wild and no public exploit code.

## Other vulnerabilities in Apache Guacamole

- [CVE-2021-43999](https://insights.sbomify.com/CVE-2021-43999/): Improper validation of SAML responses (high 8.8)
- [CVE-2017-3158](https://insights.sbomify.com/CVE-2017-3158/): Apache Guacamole Race Condition vulnerability (high 8.1)
- [CVE-2023-43826](https://insights.sbomify.com/CVE-2023-43826/): Apache Guacamole: Integer overflow in handling of VNC image buffers (high 7.5)
- [CVE-2019-19603](https://insights.sbomify.com/CVE-2019-19603/): Null dereference in n/a (high 7.5)
- [CVE-2018-1340](https://insights.sbomify.com/CVE-2018-1340/): Missing Encryption of Sensitive Data in Apache Guacamole (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41767 and fix it if it is affected.

What it is: CVE-2021-41767 is a medium-severity vulnerability in Apache Guacamole, published on 11 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41767 in the wild and no public exploit code.

Affected packages and fixed versions:
- guacamole (Bitnami): affected all versions; fixed in 1.3.0
- guacamole-server (Bitnami): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41767/ (Markdown: https://insights.sbomify.com/CVE-2021-41767/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41767
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41767
- OSV: https://osv.dev/vulnerability/CVE-2021-41767

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41767/
Summaries are generated and may contain mistakes; the official description above is the record.
