# CVE-2021-41773: Apache HTTP Server Path Traversal

> Attackers can exploit path traversal to read files outside web directories or execute code if CGI is enabled, affecting Apache HTTP Server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Yes, since 3 Nov 2021 (CISA KEV), used in ransomware
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2021
- **Updated:** 21 Oct 2025
- **Also known as:** ALPINE-CVE-2021-41773, BIT-apache-2021-41773, CLEANSTART-2026-ZP32525, DEBIAN-CVE-2021-41773, GHSA-29h7-gr57-5f8r

## What is CVE-2021-41773?

CVE-2021-41773 is a high-severity path traversal vulnerability in Apache Http Server, published on 5 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-41773?

1 open source package ship an affected version, including apache. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.49 | 2.4.50 |

Products: Apache Http Server, Fedoraproject Fedora, Netapp Cloud Backup, Oracle Instantis Enterprisetrack.

## How do I fix CVE-2021-41773?

Upgrade apache to 2.4.50 or later. US federal agencies must fix it by 17 Nov 2021.

## Is CVE-2021-41773 being exploited?

Yes. Attackers have exploited CVE-2021-41773 in the wild since at least 3 Nov 2021, including in ransomware campaigns.

Public exploit code:

- CVE-2021-41773 playground (github_poc): https://github.com/blasty/CVE-2021-41773
- CVE-2021-41773 CVE-2021-42013漏洞批量检测工具 (github_poc): https://github.com/inbug-team/CVE-2021-41773_CVE-2021-42013
- Apache2 2.4.49 - LFI & RCE Exploit - CVE-2021-41773 (github_poc): https://github.com/thehackersbrain/CVE-2021-41773
- A framework for bug hunting or pentesting targeting websites that have CVE-2021-41773 Vulnerability in public  (github_poc): https://github.com/HightechSec/scarce-apache2
- Tool check: CVE-2021-41773, CVE-2021-42013, CVE-2020-17519 (github_poc): https://github.com/MrCl0wnLab/SimplesApachePathTraversal
- https://github.com/iilegacyyii/PoC-CVE-2021-41773 (github_poc): https://github.com/iilegacyyii/PoC-CVE-2021-41773

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2010-0425](https://insights.sbomify.com/CVE-2010-0425/): Use after free in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41773 and fix it if it is affected.

What it is: CVE-2021-41773 is a high-severity path traversal vulnerability in Apache Http Server, published on 5 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2021-41773 in the wild since at least 3 Nov 2021, including in ransomware campaigns.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.49; fixed in 2.4.50

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41773/ (Markdown: https://insights.sbomify.com/CVE-2021-41773/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41773
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41773
- OSV: https://osv.dev/vulnerability/CVE-2021-41773

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41773/
Summaries are generated and may contain mistakes; the official description above is the record.
