# CVE-2021-4180: Exposure of Sensitive Information to an Unauthorized Actor in OpenStack tripleo-heat-templates

> An attacker can discover internal IP addresses or hostnames by inspecting visible configuration parameters in OpenStack TripleO Heat Templates.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hm3x-jwwf-jpr9, PYSEC-2026-753, RHSA-2022:0995, RHSA-2022:8796, UBUNTU-CVE-2021-4180

## What is CVE-2021-4180?

CVE-2021-4180 is a medium-severity vulnerability in Redhat Openstack, published on 23 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An information exposure flaw in openstack-tripleo-heat-templates allows an external user to discover the internal IP or hostname. An attacker could exploit this by checking the www_authenticate_uri parameter (which is visible to all end users) in configuration files. This would give sensitive information which may aid in additional system exploitation. This flaw affects openstack-tripleo-heat-templates versions prior to 11.6.1.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-4180?

3 open source packages ship an affected version, including tripleo-heat-templates. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tripleo-heat-templates` | PyPI | All versions | 11.6.1 |
| `tripleo-heat-templates` | PyPI | All versions | 11.6.1 |
| `tripleo-heat-templates` | PyPI | All versions | 11.6.1 |
| `openstack-tripleo-heat-templates` | Red Hat:openstack:16.1::el8 | All versions | 0:11.3.2-1.20221013153262.el8ost |
| `openstack-tripleo-heat-templates` | Red Hat:openstack:16.2::el8 | All versions | 0:11.6.1-2.20220116004912.el8ost |

Products: Openstack Tripleo Heat Templates, Redhat Openstack.

## How do I fix CVE-2021-4180?

Upgrade tripleo-heat-templates to 11.6.1 or later.

## Is CVE-2021-4180 being exploited?

There is no known exploitation of CVE-2021-4180 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openstack

- [CVE-2018-10898](https://insights.sbomify.com/CVE-2018-10898/): Hardcoded credentials in openstack-tripleo-heat-templates (high 8.8)
- [CVE-2015-5271](https://insights.sbomify.com/CVE-2015-5271/): TripleO Heat templates might allow remote attackers to obtain sensitive information from private containers (high 7.5)
- [CVE-2015-5303](https://insights.sbomify.com/CVE-2015-5303/): OpenStack TripleO Heat templates spoof metadata requests (high 7.5)
- [CVE-2021-3585](https://insights.sbomify.com/CVE-2021-3585/): Information disclosure in openstack/tripleo-heat-templates. (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4180 and fix it if it is affected.

What it is: CVE-2021-4180 is a medium-severity vulnerability in Redhat Openstack, published on 23 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-4180 in the wild and no public exploit code.

Affected packages and fixed versions:
- tripleo-heat-templates (PyPI): affected all versions; fixed in 11.6.1
- tripleo-heat-templates (PyPI): affected all versions; fixed in 11.6.1
- tripleo-heat-templates (PyPI): affected all versions; fixed in 11.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4180/ (Markdown: https://insights.sbomify.com/CVE-2021-4180/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4180
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4180
- OSV: https://osv.dev/vulnerability/CVE-2021-4180

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4180/
Summaries are generated and may contain mistakes; the official description above is the record.
