# CVE-2021-41800: MediaWiki allows a denial of service

> Attackers can cause denial of service in MediaWiki by triggering long-running SQL queries via Special:Contributions due to mishandled PoolCounter protection.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-mediawiki-2021-41800, DEBIAN-CVE-2021-41800, GHSA-c8wv-qwwc-6j73, UBUNTU-CVE-2021-41800

## What is CVE-2021-41800?

CVE-2021-41800 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 11 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MediaWiki before 1.36.2 allows a denial of service (resource consumption because of lengthy query processing time). Visiting Special:Contributions can sometimes result in a long running SQL query because PoolCounter protection is mishandled.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2021-41800?

3 open source packages ship an affected version, including mediawiki/core and mediawiki. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/core` | Packagist | All versions | 1.36.2 |
| `mediawiki/core` | Packagist | All versions | 1.36.2 |
| `mediawiki` | Bitnami | All versions | 1.36.2 |

Products: Fedoraproject Fedora, Mediawiki Mediawiki.

## How do I fix CVE-2021-41800?

Upgrade mediawiki/core to 1.36.2 or later.

## Is CVE-2021-41800 being exploited?

There is no known exploitation of CVE-2021-41800 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41800 and fix it if it is affected.

What it is: CVE-2021-41800 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 11 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41800 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki/core (Packagist): affected all versions; fixed in 1.36.2
- mediawiki/core (Packagist): affected all versions; fixed in 1.36.2
- mediawiki (Bitnami): affected all versions; fixed in 1.36.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41800/ (Markdown: https://insights.sbomify.com/CVE-2021-41800/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41800
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41800
- OSV: https://osv.dev/vulnerability/CVE-2021-41800

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41800/
Summaries are generated and may contain mistakes; the official description above is the record.
