CVE-2021-41801 Missing authorization in n/a
Blocked users can still execute text replacement jobs in MediaWiki, allowing unauthorized data modification despite access restrictions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-41801?
CVE-2021-41801 is a high-severity missing authorization vulnerability in Mediawiki Mediawiki, published on 11 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The ReplaceText extension through 1.41 for MediaWiki has Incorrect Access Control. When a user is blocked after submitting a replace job, the job is still run, even if it may be run at a later time (due to the job queue backlog)
Which versions are affected by CVE-2021-41801?
1 open source package ship an affected version, including mediawiki. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.31.16, 1.35.4, 1.36.2 |
Products include Mediawiki Mediawiki.
How do I fix CVE-2021-41801?
Upgrade mediawiki to a fixed version for your release line: 1.31.16, 1.35.4 or 1.36.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-41801 being exploited?
There is no known exploitation of CVE-2021-41801 in the wild and no public exploit code.
Other vulnerabilities in Mediawiki Mediawiki
Sources
Also known as BIT-mediawiki-2021-41801, DEBIAN-CVE-2021-41801, GHSA-rggw-5h76-8v9h, UBUNTU-CVE-2021-41801.