# CVE-2021-41801: Missing authorization in n/a

> Blocked users can still execute text replacement jobs in MediaWiki, allowing unauthorized data modification despite access restrictions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-mediawiki-2021-41801, DEBIAN-CVE-2021-41801, GHSA-rggw-5h76-8v9h, UBUNTU-CVE-2021-41801

## What is CVE-2021-41801?

CVE-2021-41801 is a high-severity missing authorization vulnerability in Mediawiki Mediawiki, published on 11 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The ReplaceText extension through 1.41 for MediaWiki has Incorrect Access Control. When a user is blocked after submitting a replace job, the job is still run, even if it may be run at a later time (due to the job queue backlog)

## Which versions are affected by CVE-2021-41801?

1 open source package ship an affected version, including mediawiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.31.16, 1.35.4, 1.36.2 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2021-41801?

Upgrade mediawiki to a fixed version for your release line: 1.31.16, 1.35.4 or 1.36.2.

## Is CVE-2021-41801 being exploited?

There is no known exploitation of CVE-2021-41801 in the wild and no public exploit code.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41801 and fix it if it is affected.

What it is: CVE-2021-41801 is a high-severity missing authorization vulnerability in Mediawiki Mediawiki, published on 11 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41801 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.31.16, 1.35.4, 1.36.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41801/ (Markdown: https://insights.sbomify.com/CVE-2021-41801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41801
- OSV: https://osv.dev/vulnerability/CVE-2021-41801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41801/
Summaries are generated and may contain mistakes; the official description above is the record.
