# CVE-2021-41802: Hashicorp Vault Privilege Escalation Vulnerability

> A user with write access to an entity alias can merge identities to acquire another user's policies, leading to privilege escalation.

- **Severity:** Low 2.9 (`CVSS:3.1/AC:L/AV:A/A:N/C:L/I:N/PR:H/S:C/UI:R`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-vault-2021-41802, GHSA-qv95-g3gm-x542, GO-2022-0618

## What is CVE-2021-41802?

CVE-2021-41802 is a low-severity vulnerability in Hashicorp Vault, published on 8 Oct 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

HashiCorp Vault and Vault Enterprise through 1.7.4 and 1.8.3 allowed a user with write permission to an entity alias ID sharing a mount accessor with another user to acquire this other user’s policies by merging their identities. Fixed in Vault and Vault Enterprise 1.7.5 and 1.8.4.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2021-41802?

6 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | All versions | 1.7.5, 1.8.4 |
| `github.com/hashicorp/vault` | Go | All versions | 1.7.5 |
| `github.com/hashicorp/vault` | Go | All versions | 1.7.5 |
| `github.com/hashicorp/vault` | Go | From 1.8.0 | 1.8.4 |
| `github.com/hashicorp/vault` | Go | From 1.8.0 | 1.8.4 |
| `vault` | Bitnami | All versions | 1.7.5, 1.8.4 |

Products: Hashicorp Vault.

## How do I fix CVE-2021-41802?

Upgrade github.com/hashicorp/vault to a fixed version for your release line: 1.7.5 or 1.8.4.

## Is CVE-2021-41802 being exploited?

There is no known exploitation of CVE-2021-41802 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41802 and fix it if it is affected.

What it is: CVE-2021-41802 is a low-severity vulnerability in Hashicorp Vault, published on 8 Oct 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-41802 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.7.5, 1.8.4
- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.7.5
- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.7.5
- github.com/hashicorp/vault (Go): affected from 1.8.0; fixed in 1.8.4
- github.com/hashicorp/vault (Go): affected from 1.8.0; fixed in 1.8.4
- vault (Bitnami): affected all versions; fixed in 1.7.5, 1.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41802/ (Markdown: https://insights.sbomify.com/CVE-2021-41802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41802
- OSV: https://osv.dev/vulnerability/CVE-2021-41802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41802/
Summaries are generated and may contain mistakes; the official description above is the record.
