CVE-2021-41805 Privilege escalation in n/a
Attackers with an ACL token in one namespace can escalate privileges in another namespace due to incorrect access control in HashiCorp Consul Enterprise.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-41805?
CVE-2021-41805 is a high-severity vulnerability in n/a, published on 12 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
HashiCorp Consul Enterprise before 1.8.17, 1.9.x before 1.9.11, and 1.10.x before 1.10.4 has Incorrect Access Control. An ACL token (with the default operator:write permissions) in one namespace can be used for unintended privilege escalation in a different namespace.
Weakness: CWE-863
Which versions are affected by CVE-2021-41805?
1 open source package ship an affected version, including consul. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
consul Bitnami | From 1.7.0 | 1.8.17, 1.9.11, 1.10.4 |
Products include Hashicorp Consul.
How do I fix CVE-2021-41805?
Upgrade consul to a fixed version for your release line: 1.8.17, 1.9.11 or 1.10.4.
Is CVE-2021-41805 being exploited?
There is no known exploitation of CVE-2021-41805 in the wild and no public exploit code.
Public exploit code: 2 proofs of concept on GitHub.
Other vulnerabilities in n/a
- CVE-2021-37219 HashiCorp Consul Privilege Escalation Vulnerability
- CVE-2023-2816 Consul Envoy Extension Downsteam Proxy Configuration By Upstream Service Owner
- CVE-2024-10006 Consul L7 Intentions Vulnerable To Headers Bypass
- CVE-2024-10005 Consul L7 Intentions Vulnerable To URL Path Bypass
- CVE-2019-8336 HashiCorp Consul Access Restriction Bypass
Sources
Also known as BIT-consul-2021-41805, GHSA-crxx-35wq-w63c, UBUNTU-CVE-2021-41805.