CVE-2021-41816 Buffer overrun in CGI.escape_html
An integer overflow in Ruby's CGI library allows attackers to trigger a buffer overflow via long strings, potentially leading to code execution or crashes.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-41816?
CVE-2021-41816 is a critical vulnerability in Fedoraproject Fedora, published on 6 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
CGI.escape_html in Ruby before 2.7.5 and 3.x before 3.0.3 has an integer overflow and resultant buffer overflow via a long string on platforms (such as Windows) where size_t and long have different numbers of bytes. This also affects the CGI gem before 0.3.1 for Ruby.
Weakness: CWE-190
Which versions are affected by CVE-2021-41816?
6 open source packages ship an affected version, including cgi. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
cgi RubyGems | All versions | 0.1.0.1 |
cgi RubyGems | All versions | 0.1.0.1 |
cgi RubyGems | From 0.2.0 | 0.2.1 |
cgi RubyGems | From 0.2.0 | 0.2.1 |
cgi RubyGems | From 0.3.0 | 0.3.1 |
cgi RubyGems | From 0.3.0 | 0.3.1 |
Products include Fedoraproject Fedora, Ruby-Lang Cgi.
How do I fix CVE-2021-41816?
Upgrade cgi to a fixed version for your release line: 0.1.0.1, 0.2.1 or 0.3.1.
Is CVE-2021-41816 being exploited?
There is no known exploitation of CVE-2021-41816 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as ALPINE-CVE-2021-41816, CLEANSTART-2026-RW40260, DEBIAN-CVE-2021-41816, GHSA-5cqm-crxm-6qpv, UBUNTU-CVE-2021-41816.