{"answers":{"affected":"6 open source packages ship an affected version, including cgi. It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-41816 in the wild and no public exploit code.","fix":"Upgrade cgi to a fixed version for your release line: 0.1.0.1, 0.2.1 or 0.3.1.","what":"CVE-2021-41816 is a critical vulnerability in Fedoraproject Fedora, published on 6 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41816 and fix it if it is affected.\n\nWhat it is: CVE-2021-41816 is a critical vulnerability in Fedoraproject Fedora, published on 6 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41816 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cgi (RubyGems): affected all versions; fixed in 0.1.0.1\n- cgi (RubyGems): affected all versions; fixed in 0.1.0.1\n- cgi (RubyGems): affected from 0.2.0; fixed in 0.2.1\n- cgi (RubyGems): affected from 0.2.0; fixed in 0.2.1\n- cgi (RubyGems): affected from 0.3.0; fixed in 0.3.1\n- cgi (RubyGems): affected from 0.3.0; fixed in 0.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41816/ (Markdown: https://insights.sbomify.com/CVE-2021-41816/index.md)","id":"CVE-2021-41816","markdown":"https://insights.sbomify.com/CVE-2021-41816/index.md","name":"CVE-2021-41816","record":{"aliases":["ALPINE-CVE-2021-41816","CLEANSTART-2026-RW40260","DEBIAN-CVE-2021-41816","GHSA-5cqm-crxm-6qpv","UBUNTU-CVE-2021-41816"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby CGI library","requires_auth":"none","summary":"An integer overflow in Ruby's CGI library allows attackers to trigger a buffer overflow via long strings, potentially leading to code execution or crashes.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"cgi","vendor":"ruby-lang"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"CGI.escape_html in Ruby before 2.7.5 and 3.x before 3.0.3 has an integer overflow and resultant buffer overflow via a long string on platforms (such as Windows) where size_t and long have different numbers of bytes. This also affects the CGI gem before 0.3.1 for Ruby.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Buffer overrun in CGI.escape_html","id":"CVE-2021-41816","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"integer_overflow","year":"2021"},"n_packages":6,"n_references":7,"next":{"headline":"Regular expression denial of service vulnerability (ReDoS) in date","id":"CVE-2021-41817"},"packages":[{"ecosystem":"RubyGems","fixed":["0.1.0.1"],"introduced":["0"],"last_affected":[],"package":"cgi","purl":null,"source":"GHSA-5cqm-crxm-6qpv"},{"ecosystem":"RubyGems","fixed":["0.1.0.1"],"introduced":["0"],"last_affected":[],"package":"cgi","purl":"pkg:gem/cgi","source":"GHSA-5cqm-crxm-6qpv"},{"ecosystem":"RubyGems","fixed":["0.2.1"],"introduced":["0.2.0"],"last_affected":[],"package":"cgi","purl":null,"source":"GHSA-5cqm-crxm-6qpv"},{"ecosystem":"RubyGems","fixed":["0.2.1"],"introduced":["0.2.0"],"last_affected":[],"package":"cgi","purl":"pkg:gem/cgi","source":"GHSA-5cqm-crxm-6qpv"},{"ecosystem":"RubyGems","fixed":["0.3.1"],"introduced":["0.3.0"],"last_affected":[],"package":"cgi","purl":null,"source":"GHSA-5cqm-crxm-6qpv"},{"ecosystem":"RubyGems","fixed":["0.3.1"],"introduced":["0.3.0"],"last_affected":[],"package":"cgi","purl":"pkg:gem/cgi","source":"GHSA-5cqm-crxm-6qpv"}],"prev":{"headline":"Script injection in M-Files Admin","id":"CVE-2021-41810"},"products":["n/a"],"published":"2022-02-06","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An integer overflow in Ruby's CGI library allows attackers to trigger a buffer overflow via long strings, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2021-41816/"}