# CVE-2021-41816: Buffer overrun in CGI.escape_html

> An integer overflow in Ruby's CGI library allows attackers to trigger a buffer overflow via long strings, potentially leading to code execution or crashes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2022
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2021-41816, CLEANSTART-2026-RW40260, DEBIAN-CVE-2021-41816, GHSA-5cqm-crxm-6qpv, UBUNTU-CVE-2021-41816

## What is CVE-2021-41816?

CVE-2021-41816 is a critical vulnerability in Fedoraproject Fedora, published on 6 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CGI.escape_html in Ruby before 2.7.5 and 3.x before 3.0.3 has an integer overflow and resultant buffer overflow via a long string on platforms (such as Windows) where size_t and long have different numbers of bytes. This also affects the CGI gem before 0.3.1 for Ruby.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2021-41816?

6 open source packages ship an affected version, including cgi. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cgi` | RubyGems | All versions | 0.1.0.1 |
| `cgi` | RubyGems | All versions | 0.1.0.1 |
| `cgi` | RubyGems | From 0.2.0 | 0.2.1 |
| `cgi` | RubyGems | From 0.2.0 | 0.2.1 |
| `cgi` | RubyGems | From 0.3.0 | 0.3.1 |
| `cgi` | RubyGems | From 0.3.0 | 0.3.1 |

Products: Fedoraproject Fedora, Ruby-Lang Cgi.

## How do I fix CVE-2021-41816?

Upgrade cgi to a fixed version for your release line: 0.1.0.1, 0.2.1 or 0.3.1.

## Is CVE-2021-41816 being exploited?

There is no known exploitation of CVE-2021-41816 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41816 and fix it if it is affected.

What it is: CVE-2021-41816 is a critical vulnerability in Fedoraproject Fedora, published on 6 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41816 in the wild and no public exploit code.

Affected packages and fixed versions:
- cgi (RubyGems): affected all versions; fixed in 0.1.0.1
- cgi (RubyGems): affected all versions; fixed in 0.1.0.1
- cgi (RubyGems): affected from 0.2.0; fixed in 0.2.1
- cgi (RubyGems): affected from 0.2.0; fixed in 0.2.1
- cgi (RubyGems): affected from 0.3.0; fixed in 0.3.1
- cgi (RubyGems): affected from 0.3.0; fixed in 0.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41816/ (Markdown: https://insights.sbomify.com/CVE-2021-41816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41816
- OSV: https://osv.dev/vulnerability/CVE-2021-41816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41816/
Summaries are generated and may contain mistakes; the official description above is the record.
