# CVE-2021-41817: Regular expression denial of service vulnerability (ReDoS) in date

> Attackers can cause denial of service in Ruby applications using the date gem by submitting long strings to Date.parse.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jan 2022
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2021-41817, AZL-7110, BIT-ruby-2021-41817, BIT-ruby-min-2021-41817, CLEANSTART-2026-KK38106, DEBIAN-CVE-2021-41817, GHSA-qg54-694p-wgpp, JLSEC-2026-1287, OESA-2024-2581, UBUNTU-CVE-2021-41817

## What is CVE-2021-41817?

CVE-2021-41817 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 1 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Date.parse in the date gem through 3.2.0 for Ruby allows ReDoS (regular expression Denial of Service) via a long string. The fixed versions are 3.2.1, 3.1.2, 3.0.2, and 2.0.1.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-41817?

10 open source packages ship an affected version, including date, ruby and ruby-min. It affects 9 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `date` | RubyGems | All versions | 2.0.1 |
| `date` | RubyGems | All versions | 2.0.1 |
| `date` | RubyGems | From 3.0.0 | 3.0.2 |
| `date` | RubyGems | From 3.0.0 | 3.0.2 |
| `date` | RubyGems | From 3.1.0 | 3.1.2 |
| `date` | RubyGems | From 3.1.0 | 3.1.2 |
| `date` | RubyGems | From 3.2.0 | 3.2.1 |
| `date` | RubyGems | From 3.2.0 | 3.2.1 |
| `ruby` | Bitnami | From 2.6.0 | 2.6.9, 2.7.5, 3.0.3 |
| `ruby-min` | Bitnami | From 2.6.0 | 2.6.9, 2.7.5, 3.0.3 |

Products: Debian Debian Linux, Fedoraproject Fedora, Opensuse Factory, Opensuse Leap, Redhat Enterprise Linux, Redhat Software Collections, Ruby-Lang Date, Ruby-Lang Ruby, Suse Linux Enterprise.

## How do I fix CVE-2021-41817?

Upgrade date to a fixed version for your release line: 2.0.1, 3.0.2, 3.1.2 or 3.2.1.

## Is CVE-2021-41817 being exploited?

There is no known exploitation of CVE-2021-41817 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41817 and fix it if it is affected.

What it is: CVE-2021-41817 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 1 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41817 in the wild and no public exploit code.

Affected packages and fixed versions:
- date (RubyGems): affected all versions; fixed in 2.0.1
- date (RubyGems): affected all versions; fixed in 2.0.1
- date (RubyGems): affected from 3.0.0; fixed in 3.0.2
- date (RubyGems): affected from 3.0.0; fixed in 3.0.2
- date (RubyGems): affected from 3.1.0; fixed in 3.1.2
- date (RubyGems): affected from 3.1.0; fixed in 3.1.2
- date (RubyGems): affected from 3.2.0; fixed in 3.2.1
- date (RubyGems): affected from 3.2.0; fixed in 3.2.1
- ruby (Bitnami): affected from 2.6.0; fixed in 2.6.9, 2.7.5, 3.0.3
- ruby-min (Bitnami): affected from 2.6.0; fixed in 2.6.9, 2.7.5, 3.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41817/ (Markdown: https://insights.sbomify.com/CVE-2021-41817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41817
- OSV: https://osv.dev/vulnerability/CVE-2021-41817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41817/
Summaries are generated and may contain mistakes; the official description above is the record.
