CVE-2021-41819 Cookie Prefix Spoofing in CGI::Cookie.parse
Attackers can bypass cookie security prefixes in Ruby's CGI library, potentially leading to cookie manipulation or session hijacking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-41819?
CVE-2021-41819 is a high-severity vulnerability in Debian Debian Linux, published on 1 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
CGI::Cookie.parse in Ruby through 2.6.8 mishandles security prefixes in cookie names. This also affects the CGI gem through 0.3.0 for Ruby.
Weakness: CWE-565
Which versions are affected by CVE-2021-41819?
8 open source packages ship an affected version, including cgi, ruby and ruby-min. It affects 9 products.
| Package | Affected | Fixed in |
|---|---|---|
cgi RubyGems | All versions | 0.1.0.1 |
cgi RubyGems | All versions | 0.1.0.1 |
cgi RubyGems | From 0.2.0 | 0.2.1 |
cgi RubyGems | From 0.2.0 | 0.2.1 |
cgi RubyGems | From 0.3.0 | 0.3.1 |
cgi RubyGems | From 0.3.0 | 0.3.1 |
2 more packages
ruby Bitnami | All versions | 2.6.9, 2.7.5, 3.0.3 |
ruby-min Bitnami | All versions | 2.6.9, 2.7.5, 3.0.3 |
Linux distribution packages (4)
ruby2.5 SUSE:Linux Enterprise Module for Basesystem 15 SP3 | All versions | 2.5.9-150000.4.26.1 |
ruby2.5 SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 2.5.9-150000.4.26.1 |
ruby2.5 openSUSE:Leap 15.3 | All versions | 2.5.9-150000.4.26.1 |
ruby2.5 openSUSE:Leap 15.4 | All versions | 2.5.9-150000.4.26.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Opensuse Factory, Opensuse Leap, Redhat Enterprise Linux, Redhat Software Collections and 3 more.
How do I fix CVE-2021-41819?
Upgrade cgi to a fixed version for your release line: 0.1.0.1, 0.2.1 or 0.3.1.
Is CVE-2021-41819 being exploited?
There is no known exploitation of CVE-2021-41819 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2021-41819, AZL-7126, BIT-ruby-2021-41819, BIT-ruby-min-2021-41819, CLEANSTART-2026-RI06659, CLSA-2024-1727115733 and 6 more.