# CVE-2021-41819: Cookie Prefix Spoofing in CGI::Cookie.parse

> Attackers can bypass cookie security prefixes in Ruby's CGI library, potentially leading to cookie manipulation or session hijacking.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jan 2022
- **Updated:** 22 May 2025
- **Also known as:** ALPINE-CVE-2021-41819, AZL-7126, BIT-ruby-2021-41819, BIT-ruby-min-2021-41819, CLEANSTART-2026-RI06659, CLSA-2024-1727115733, DEBIAN-CVE-2021-41819, GHSA-4vf4-qmvg-mh7h, JLSEC-2026-1288, OESA-2022-1497, SUSE-SU-2022:3292-1, UBUNTU-CVE-2021-41819

## What is CVE-2021-41819?

CVE-2021-41819 is a high-severity vulnerability in Debian Debian Linux, published on 1 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CGI::Cookie.parse in Ruby through 2.6.8 mishandles security prefixes in cookie names. This also affects the CGI gem through 0.3.0 for Ruby.

Weakness: CWE-565 (Reliance on Cookies without Validation and Integrity Checking)

## Which versions are affected by CVE-2021-41819?

8 open source packages ship an affected version, including cgi, ruby and ruby-min. It affects 9 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cgi` | RubyGems | All versions | 0.1.0.1 |
| `cgi` | RubyGems | All versions | 0.1.0.1 |
| `cgi` | RubyGems | From 0.2.0 | 0.2.1 |
| `cgi` | RubyGems | From 0.2.0 | 0.2.1 |
| `cgi` | RubyGems | From 0.3.0 | 0.3.1 |
| `cgi` | RubyGems | From 0.3.0 | 0.3.1 |
| `ruby` | Bitnami | All versions | 2.6.9, 2.7.5, 3.0.3 |
| `ruby-min` | Bitnami | All versions | 2.6.9, 2.7.5, 3.0.3 |
| `ruby2.5` | SUSE:Linux Enterprise Module for Basesystem 15 SP3 | All versions | 2.5.9-150000.4.26.1 |
| `ruby2.5` | SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 2.5.9-150000.4.26.1 |
| `ruby2.5` | openSUSE:Leap 15.3 | All versions | 2.5.9-150000.4.26.1 |
| `ruby2.5` | openSUSE:Leap 15.4 | All versions | 2.5.9-150000.4.26.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Opensuse Factory, Opensuse Leap, Redhat Enterprise Linux, Redhat Software Collections, Ruby-Lang Cgi, Ruby-Lang Ruby, Suse Linux Enterprise.

## How do I fix CVE-2021-41819?

Upgrade cgi to a fixed version for your release line: 0.1.0.1, 0.2.1 or 0.3.1.

## Is CVE-2021-41819 being exploited?

There is no known exploitation of CVE-2021-41819 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41819 and fix it if it is affected.

What it is: CVE-2021-41819 is a high-severity vulnerability in Debian Debian Linux, published on 1 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41819 in the wild and no public exploit code.

Affected packages and fixed versions:
- cgi (RubyGems): affected all versions; fixed in 0.1.0.1
- cgi (RubyGems): affected all versions; fixed in 0.1.0.1
- cgi (RubyGems): affected from 0.2.0; fixed in 0.2.1
- cgi (RubyGems): affected from 0.2.0; fixed in 0.2.1
- cgi (RubyGems): affected from 0.3.0; fixed in 0.3.1
- cgi (RubyGems): affected from 0.3.0; fixed in 0.3.1
- ruby (Bitnami): affected all versions; fixed in 2.6.9, 2.7.5, 3.0.3
- ruby-min (Bitnami): affected all versions; fixed in 2.6.9, 2.7.5, 3.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41819/ (Markdown: https://insights.sbomify.com/CVE-2021-41819/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41819
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41819
- OSV: https://osv.dev/vulnerability/CVE-2021-41819

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41819/
Summaries are generated and may contain mistakes; the official description above is the record.
