{"answers":{"affected":"2 open source packages ship an affected version, including com.googlecode.aviator:aviator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41862 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2021-41862 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-41862 is a critical code injection vulnerability in n/a, published on 1 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41862 and fix it if it is affected.\n\nWhat it is: CVE-2021-41862 is a critical code injection vulnerability in n/a, published on 1 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41862 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.googlecode.aviator:aviator (Maven): affected from 5.2.1 up to 5.2.7; no fix listed\n- com.googlecode.aviator:aviator (Maven): affected from 5.2.1 up to 5.2.7; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41862/ (Markdown: https://insights.sbomify.com/CVE-2021-41862/index.md)","id":"CVE-2021-41862","markdown":"https://insights.sbomify.com/CVE-2021-41862/index.md","name":"CVE-2021-41862","record":{"aliases":["GHSA-xpv2-8ppj-79hh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"AviatorScript expression engine","requires_auth":"none","summary":"Attackers can execute arbitrary code by submitting malicious expressions encoded with BCEL to the AviatorScript library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"aviatorscript","vendor":"aviatorscript_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"AviatorScript through 5.2.7 allows code execution via an expression that is encoded with Byte Code Engineering Library (BCEL).","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Expression injection in AviatorScript","id":"CVE-2021-41862","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":2,"n_references":1,"next":{"headline":"Integer overflow in n/a","id":"CVE-2021-41864"},"packages":[{"ecosystem":"Maven","fixed":[],"introduced":["5.2.1"],"last_affected":["5.2.7"],"package":"com.googlecode.aviator:aviator","purl":null,"source":"GHSA-xpv2-8ppj-79hh"},{"ecosystem":"Maven","fixed":[],"introduced":["5.2.1"],"last_affected":["5.2.7"],"package":"com.googlecode.aviator:aviator","purl":"pkg:maven/com.googlecode.aviator/aviator","source":"GHSA-xpv2-8ppj-79hh"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2021-41861"},"products":["n/a"],"published":"2021-10-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code by submitting malicious expressions encoded with BCEL to the AviatorScript library.","url":"https://insights.sbomify.com/CVE-2021-41862/"}