CVE-2021-41865 Denial of service in n/a
Authenticated users can cause denial of service in HashiCorp Nomad by submitting incomplete job specifications with specific networking modes.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2021-41865?
CVE-2021-41865 is a medium-severity denial of service vulnerability in n/a, published on 7 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
HashiCorp Nomad and Nomad Enterprise 1.1.1 through 1.1.5 allowed authenticated users with job submission capabilities to cause denial of service by submitting incomplete job specifications with a Consul mesh gateway and host networking mode. Fixed in 1.1.6.
Which versions are affected by CVE-2021-41865?
It affects 1 product.
Products include Hashicorp Nomad.
How do I fix CVE-2021-41865?
No fix has been published for CVE-2021-41865 yet. Limit exposure of the affected software until one is available.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-41865 being exploited?
There is no known exploitation of CVE-2021-41865 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2023-1782 Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation
- CVE-2022-30324 Privilege escalation in Hashicorp Nomad
- CVE-2020-7956 Improper Certificate Validation in HashiCorp Nomad
- CVE-2019-12618 Hashicorp Nomad Access Control Issues
- CVE-2020-27195 Use After Free in HashiCorp Nomad
Sources
Also known as GHSA-g2jw-2jr4-qjj5, UBUNTU-CVE-2021-41865.