# CVE-2021-41865: Denial of service in n/a

> Authenticated users can cause denial of service in HashiCorp Nomad by submitting incomplete job specifications with specific networking modes.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-g2jw-2jr4-qjj5, UBUNTU-CVE-2021-41865

## What is CVE-2021-41865?

CVE-2021-41865 is a medium-severity denial of service vulnerability in n/a, published on 7 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

HashiCorp Nomad and Nomad Enterprise 1.1.1 through 1.1.5 allowed authenticated users with job submission capabilities to cause denial of service by submitting incomplete job specifications with a Consul mesh gateway and host networking mode. Fixed in 1.1.6.

## Which versions are affected by CVE-2021-41865?

It affects 1 product.


Products: Hashicorp Nomad.

## How do I fix CVE-2021-41865?

No fix has been published for CVE-2021-41865 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-41865 being exploited?

There is no known exploitation of CVE-2021-41865 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-1782](https://insights.sbomify.com/CVE-2023-1782/): Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation (critical 10.0)
- [CVE-2022-30324](https://insights.sbomify.com/CVE-2022-30324/): Privilege escalation in Hashicorp Nomad (critical 9.8)
- [CVE-2020-7956](https://insights.sbomify.com/CVE-2020-7956/): Improper Certificate Validation in HashiCorp Nomad (critical 9.8)
- [CVE-2019-12618](https://insights.sbomify.com/CVE-2019-12618/): Hashicorp Nomad Access Control Issues (critical 9.8)
- [CVE-2020-27195](https://insights.sbomify.com/CVE-2020-27195/): Use After Free in HashiCorp Nomad (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41865 and fix it if it is affected.

What it is: CVE-2021-41865 is a medium-severity denial of service vulnerability in n/a, published on 7 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41865 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41865/ (Markdown: https://insights.sbomify.com/CVE-2021-41865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41865
- OSV: https://osv.dev/vulnerability/CVE-2021-41865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41865/
Summaries are generated and may contain mistakes; the official description above is the record.
