# CVE-2021-41945: Improper Input Validation in httpx

> Improper input validation in httpx URL handling allows potential security issues, requiring users to upgrade the library.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Apr 2022
- **Updated:** 9 Jul 2026
- **Also known as:** CLSA-2025-1752797525, DEBIAN-CVE-2021-41945, GHSA-h8pj-cxx2-jfg2, PYSEC-2022-183, UBUNTU-CVE-2021-41945, openSUSE-SU-2024:12041-1, openSUSE-SU-2025:14664-1

## What is CVE-2021-41945?

CVE-2021-41945 is a critical vulnerability in n/a, published on 28 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Encode OSS httpx < 0.23.0 is affected by improper input validation in `httpx.URL`, `httpx.Client` and some functions using `httpx.URL.copy_with`.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-41945?

3 open source packages ship an affected version, including httpx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `httpx` | PyPI | All versions | 0.20.0 |
| `httpx` | PyPI | All versions | 0.23.0 |
| `httpx` | PyPI | All versions | 0.23.0 |
| `python-httpx` | openSUSE:Tumbleweed | All versions | 0.28.1-2.1 |

Products: Encode Httpx.

## How do I fix CVE-2021-41945?

Upgrade httpx to a fixed version for your release line: 0.20.0 or 0.23.0.

## Is CVE-2021-41945 being exploited?

There is no known exploitation of CVE-2021-41945 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41945 and fix it if it is affected.

What it is: CVE-2021-41945 is a critical vulnerability in n/a, published on 28 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41945 in the wild and no public exploit code.

Affected packages and fixed versions:
- httpx (PyPI): affected all versions; fixed in 0.20.0
- httpx (PyPI): affected all versions; fixed in 0.23.0
- httpx (PyPI): affected all versions; fixed in 0.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41945/ (Markdown: https://insights.sbomify.com/CVE-2021-41945/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41945
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41945
- OSV: https://osv.dev/vulnerability/CVE-2021-41945

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41945/
Summaries are generated and may contain mistakes; the official description above is the record.
