CVE-2021-41951 Cross-site scripting in n/a

Medium 6.1 Published Updated

Reflected XSS in ResourceSpace allows attackers to execute malicious JavaScript in victims' browsers via crafted URLs.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-41951?

CVE-2021-41951 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

ResourceSpace before 9.6 rev 18290 is affected by a reflected Cross-Site Scripting vulnerability in plugins/wordpress_sso/pages/index.php via the wordpress_user parameter. If an attacker is able to persuade a victim to visit a crafted URL, malicious JavaScript content may be executed within the context of the victim's browser.

Weakness: CWE-79

Which versions are affected by CVE-2021-41951?

1 open source package ship an affected version, including resourcespace. It affects 1 product.

PackageAffectedFixed in
resourcespace BitnamiAll versions to 9.6.09.6.0

Products include Montala Resourcespace.

How do I fix CVE-2021-41951?

Upgrade resourcespace to 9.6.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-41951 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-41951 exists.

Public exploit code: 1 Nuclei template.

Sources

Also known as BIT-resourcespace-2021-41951, GHSA-2xqf-mm33-4rv9.

Is CVE-2021-41951 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free