{"answers":{"affected":"4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41971 in the wild and no public exploit code.","fix":"Upgrade apache-superset to 1.3.1 or later.","what":"CVE-2021-41971 is a high-severity SQL injection vulnerability in Apache Superset, published on 18 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41971 and fix it if it is affected.\n\nWhat it is: CVE-2021-41971 is a high-severity SQL injection vulnerability in Apache Superset, published on 18 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41971 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-superset (PyPI): affected all versions; fixed in 1.3.1\n- apache-superset (PyPI): affected all versions; fixed in 1.3.1\n- apache-superset (PyPI): affected all versions; fixed in 1.3.1\n- superset (Bitnami): affected all versions; fixed in 1.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41971/ (Markdown: https://insights.sbomify.com/CVE-2021-41971/index.md)","id":"CVE-2021-41971","markdown":"https://insights.sbomify.com/CVE-2021-41971/index.md","name":"CVE-2021-41971","record":{"aliases":["BIT-superset-2021-41971","GHSA-pg8m-4p8j-2p56","PYSEC-2021-378"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Superset","requires_auth":"low_privilege","summary":"A malicious authenticated user can execute arbitrary SQL queries in Apache Superset when template processing is enabled, potentially accessing or modifying data.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"superset","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Apache Superset up to and including 1.3.0 when configured with ENABLE_TEMPLATE_PROCESSING on (disabled by default) allowed SQL injection when a malicious authenticated user sends an http request with a custom URL.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Possible SQL Injection when template processing is enabled","id":"CVE-2021-41971","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:superset","products":["apache:superset"],"type":"sql_injection","year":"2021"},"n_packages":4,"n_references":1,"next":{"headline":"Credentials leak","id":"CVE-2021-41972"},"packages":[{"ecosystem":"Bitnami","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"superset","purl":"pkg:bitnami/superset","source":"BIT-superset-2021-41971"},{"ecosystem":"PyPI","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":null,"source":"GHSA-pg8m-4p8j-2p56"},{"ecosystem":"PyPI","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"GHSA-pg8m-4p8j-2p56"},{"ecosystem":"PyPI","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"PYSEC-2021-378"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2021-41965"},"products":["Apache Superset"],"published":"2021-10-18","related":[{"cvss_score":8.9,"headline":"Apache Superset Insecure Default Initialization of Resource","id":"CVE-2023-27524","kev_date_added":"2024-01-08","published":"2023-04-24"},{"cvss_score":9.8,"headline":"SQL injection vulnerability in chart data API","id":"CVE-2022-27479","kev_date_added":null,"published":"2022-04-13"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in superset","id":"CVE-2018-8021","kev_date_added":null,"published":"2018-11-07"},{"cvss_score":9.6,"headline":"Apache Superset: Stored XSS in Dashboard Title and Chart Title","id":"CVE-2023-49657","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":8.8,"headline":"Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API","id":"CVE-2022-43719","kev_date_added":null,"published":"2023-01-16"},{"cvss_score":8.8,"headline":"Apache Superset OS Command Injection","id":"CVE-2020-13948","kev_date_added":null,"published":"2020-09-17"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Apache Software Foundation"]},"summary":"A malicious authenticated user can execute arbitrary SQL queries in Apache Superset when template processing is enabled, potentially accessing or modifying data.","url":"https://insights.sbomify.com/CVE-2021-41971/"}