# CVE-2021-41971: Possible SQL Injection when template processing is enabled

> A malicious authenticated user can execute arbitrary SQL queries in Apache Superset when template processing is enabled, potentially accessing or modifying data.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-superset-2021-41971, GHSA-pg8m-4p8j-2p56, PYSEC-2021-378

## What is CVE-2021-41971?

CVE-2021-41971 is a high-severity SQL injection vulnerability in Apache Superset, published on 18 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Superset up to and including 1.3.0 when configured with ENABLE_TEMPLATE_PROCESSING on (disabled by default) allowed SQL injection when a malicious authenticated user sends an http request with a custom URL.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2021-41971?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 1.3.1 |
| `apache-superset` | PyPI | All versions | 1.3.1 |
| `apache-superset` | PyPI | All versions | 1.3.1 |
| `superset` | Bitnami | All versions | 1.3.1 |

Products: Apache Superset.

## How do I fix CVE-2021-41971?

Upgrade apache-superset to 1.3.1 or later.

## Is CVE-2021-41971 being exploited?

There is no known exploitation of CVE-2021-41971 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41971 and fix it if it is affected.

What it is: CVE-2021-41971 is a high-severity SQL injection vulnerability in Apache Superset, published on 18 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41971 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 1.3.1
- apache-superset (PyPI): affected all versions; fixed in 1.3.1
- apache-superset (PyPI): affected all versions; fixed in 1.3.1
- superset (Bitnami): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41971/ (Markdown: https://insights.sbomify.com/CVE-2021-41971/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41971
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41971
- OSV: https://osv.dev/vulnerability/CVE-2021-41971

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41971/
Summaries are generated and may contain mistakes; the official description above is the record.
