# CVE-2021-41973: Apache MINA HTTP listener DOS

> A malformed HTTP request can cause the Apache MINA HTTP Header decoder to loop indefinitely, leading to a denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** CLEANSTART-2026-YP61169, DEBIAN-CVE-2021-41973, GHSA-6mcm-j9cj-3vc3, OESA-2021-1435, UBUNTU-CVE-2021-41973

## What is CVE-2021-41973?

CVE-2021-41973 is a medium-severity denial of service vulnerability in Oracle Flexcube Universal Banking, published on 1 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Apache MINA, a specifically crafted, malformed HTTP request may cause the HTTP Header decoder to loop indefinitely. The decoder assumed that the HTTP Header begins at the beginning of the buffer and loops if there is more data than expected. Please update MINA to 2.1.5 or greater.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2021-41973?

4 open source packages ship an affected version, including org.apache.mina:mina-core. It affects 9 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.mina:mina-core` | Maven | All versions | 2.0.22 |
| `org.apache.mina:mina-core` | Maven | All versions | 2.0.22 |
| `org.apache.mina:mina-core` | Maven | From 2.1.0 | 2.1.5 |
| `org.apache.mina:mina-core` | Maven | From 2.1.0 | 2.1.5 |

Products: Apache Mina, Oracle Banking Payments, Oracle Banking Trade Finance Process Management, Oracle Banking Treasury Management, Oracle Communications Cloud Native Core Console, Oracle Customer Management and Segmentation Foundation, Oracle Flexcube Universal Banking, Oracle Fusion Middleware Common Libraries and Tools, Oracle Oss Support Tools.

## How do I fix CVE-2021-41973?

Upgrade org.apache.mina:mina-core to a fixed version for your release line: 2.0.22 or 2.1.5.

## Is CVE-2021-41973 being exploited?

There is no known exploitation of CVE-2021-41973 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Flexcube Universal Banking

- [CVE-2024-52046](https://insights.sbomify.com/CVE-2024-52046/): Apache MINA: MINA applications using unbounded deserialization may allow RCE (critical 10.0)
- [CVE-2026-47065](https://insights.sbomify.com/CVE-2026-47065/): Apache MINA: Critical Deserialization Allow-list Bypass via resolveProxyClass - ZDRES-232 (critical 9.8)
- [CVE-2026-42778](https://insights.sbomify.com/CVE-2026-42778/): Apache MINA: CWE-502 Deserialization of Untrusted Data (take 2) (critical 9.8)
- [CVE-2026-42779](https://insights.sbomify.com/CVE-2026-42779/): Apache MINA vulnerable to Deserialization of Untrusted Data (CVE-2026-41635 Incomplete Fix) (critical 9.8)
- [CVE-2026-41409](https://insights.sbomify.com/CVE-2026-41409/): Apache MINA: CWE-502 Deserialization of Untrusted Data (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41973 and fix it if it is affected.

What it is: CVE-2021-41973 is a medium-severity denial of service vulnerability in Oracle Flexcube Universal Banking, published on 1 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-41973 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.mina:mina-core (Maven): affected all versions; fixed in 2.0.22
- org.apache.mina:mina-core (Maven): affected all versions; fixed in 2.0.22
- org.apache.mina:mina-core (Maven): affected from 2.1.0; fixed in 2.1.5
- org.apache.mina:mina-core (Maven): affected from 2.1.0; fixed in 2.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41973/ (Markdown: https://insights.sbomify.com/CVE-2021-41973/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41973
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41973
- OSV: https://osv.dev/vulnerability/CVE-2021-41973

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41973/
Summaries are generated and may contain mistakes; the official description above is the record.
