# CVE-2021-42010: CRLF log injection

> Attackers can inject CRLF characters into logs due to lack of escaping, potentially corrupting log data in Apache Heron.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Oct 2022
- **Updated:** 7 May 2025
- **Also known as:** GHSA-95w5-q9vp-5vrm

## What is CVE-2021-42010?

CVE-2021-42010 is a critical vulnerability in Apache Heron (Incubating), published on 24 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Heron versions <= 0.20.4-incubating allows CRLF log injection because of the lack of escaping in the log statements. Please update to version 0.20.5-incubating which addresses this issue.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2021-42010?

2 open source packages ship an affected version, including org.apache.heron:heron-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.heron:heron-api` | Maven | All versions | 0.20.5-incubating |
| `org.apache.heron:heron-api` | Maven | All versions | 0.20.5-incubating |

Products: Apache Heron.

## How do I fix CVE-2021-42010?

Upgrade org.apache.heron:heron-api to 0.20.5-incubating or later.

## Is CVE-2021-42010 being exploited?

There is no known exploitation of CVE-2021-42010 in the wild and no public exploit code.

## Other vulnerabilities in Apache Heron (Incubating)

- [CVE-2020-1964](https://insights.sbomify.com/CVE-2020-1964/): Deserialization of Untrusted Data in Apache Heron (critical 9.8)
- [CVE-2018-11789](https://insights.sbomify.com/CVE-2018-11789/): Path traversal in Apache Incubator Heron (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-42010 and fix it if it is affected.

What it is: CVE-2021-42010 is a critical vulnerability in Apache Heron (Incubating), published on 24 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-42010 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.heron:heron-api (Maven): affected all versions; fixed in 0.20.5-incubating
- org.apache.heron:heron-api (Maven): affected all versions; fixed in 0.20.5-incubating

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-42010/ (Markdown: https://insights.sbomify.com/CVE-2021-42010/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-42010
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-42010
- OSV: https://osv.dev/vulnerability/CVE-2021-42010

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-42010/
Summaries are generated and may contain mistakes; the official description above is the record.
