# CVE-2021-42040: Denial of service in n/a

> An attacker can cause a denial of service by triggering an infinite loop in the MediaWiki Loops extension, leading to memory exhaustion.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-mediawiki-2021-42040, GHSA-qrm9-mhjr-qfm7, UBUNTU-CVE-2021-42040

## What is CVE-2021-42040?

CVE-2021-42040 is a high-severity denial of service vulnerability in Mediawiki Mediawiki, published on 6 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in MediaWiki through 1.36.2. A parser function related to loop control allowed for an infinite loop (and php-fpm hang) within the Loops extension because egLoopsCountLimit is mishandled. This could lead to memory exhaustion.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2021-42040?

1 open source package ship an affected version, including mediawiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.36.3 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2021-42040?

Upgrade mediawiki to 1.36.3 or later.

## Is CVE-2021-42040 being exploited?

There is no known exploitation of CVE-2021-42040 in the wild and no public exploit code.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-42040 and fix it if it is affected.

What it is: CVE-2021-42040 is a high-severity denial of service vulnerability in Mediawiki Mediawiki, published on 6 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-42040 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.36.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-42040/ (Markdown: https://insights.sbomify.com/CVE-2021-42040/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-42040
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-42040
- OSV: https://osv.dev/vulnerability/CVE-2021-42040

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-42040/
Summaries are generated and may contain mistakes; the official description above is the record.
