# CVE-2021-42050: Cross-site scripting in n/a

> Attackers can execute arbitrary scripts in victim browsers via DOM-based XSS in AbanteCart, potentially leading to session hijacking or data theft.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-abantecart-2021-42050, GHSA-r87m-52m7-4wpg

## What is CVE-2021-42050?

CVE-2021-42050 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Dec 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in AbanteCart before 1.3.2. It allows DOM Based XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-42050?

1 open source package ship an affected version, including abantecart. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `abantecart` | Bitnami | All versions | 1.3.2 |

Products: Abantecart Abantecart.

## How do I fix CVE-2021-42050?

Upgrade abantecart to 1.3.2 or later.

## Is CVE-2021-42050 being exploited?

There is no known exploitation of CVE-2021-42050 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-50972](https://insights.sbomify.com/CVE-2025-50972/): SQL injection in n/a (critical 9.8)
- [CVE-2016-10755](https://insights.sbomify.com/CVE-2016-10755/): SQL injection in n/a (high 8.8)
- [CVE-2025-50971](https://insights.sbomify.com/CVE-2025-50971/): Path traversal in n/a (high 7.5)
- [CVE-2022-26521](https://insights.sbomify.com/CVE-2022-26521/): File upload in n/a (high 7.2)
- [CVE-2018-20141](https://insights.sbomify.com/CVE-2018-20141/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-42050 and fix it if it is affected.

What it is: CVE-2021-42050 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Dec 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-42050 in the wild and no public exploit code.

Affected packages and fixed versions:
- abantecart (Bitnami): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-42050/ (Markdown: https://insights.sbomify.com/CVE-2021-42050/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-42050
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-42050
- OSV: https://osv.dev/vulnerability/CVE-2021-42050

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-42050/
Summaries are generated and may contain mistakes; the official description above is the record.
