# CVE-2021-42053: Cross-site scripting in Unicorn framework

> Cross-site scripting vulnerability in the Unicorn framework for Django allows attackers to inject malicious scripts via component names.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-c87f-fq5g-63r2, PYSEC-2021-357

## What is CVE-2021-42053?

CVE-2021-42053 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Oct 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Unicorn framework through 0.35.3 for Django allows XSS via component.name.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-42053?

3 open source packages ship an affected version, including django-unicorn. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django-unicorn` | PyPI | All versions | 0.36.0 |
| `django-unicorn` | PyPI | All versions | 0.36.0 |
| `django-unicorn` | PyPI | All versions | 0.36.0 |

Products: Django-Unicorn Unicorn.

## How do I fix CVE-2021-42053?

Upgrade django-unicorn to 0.36.0 or later.

## Is CVE-2021-42053 being exploited?

There is no known exploitation of CVE-2021-42053 in the wild and no public exploit code.

Public exploit code:

- django-unicorn 0.35.3 - Stored Cross-Site Scripting (XSS) (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2021-42134](https://insights.sbomify.com/CVE-2021-42134/): Cross-site Scripting in django-unicorn (medium 6.1)
- [CVE-2026-31815](https://insights.sbomify.com/CVE-2026-31815/): django-unicorn affected by component state manipulation via unvalidated attribute access (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-42053 and fix it if it is affected.

What it is: CVE-2021-42053 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Oct 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-42053 in the wild and no public exploit code.

Affected packages and fixed versions:
- django-unicorn (PyPI): affected all versions; fixed in 0.36.0
- django-unicorn (PyPI): affected all versions; fixed in 0.36.0
- django-unicorn (PyPI): affected all versions; fixed in 0.36.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-42053/ (Markdown: https://insights.sbomify.com/CVE-2021-42053/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-42053
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-42053
- OSV: https://osv.dev/vulnerability/CVE-2021-42053

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-42053/
Summaries are generated and may contain mistakes; the official description above is the record.
