# CVE-2021-42220: Dolibarr Cross Site Scripting (XSS) vulnerability

> An attacker can execute arbitrary scripts in Dolibarr if an admin copies a malicious payload into a box, potentially leading to session hijacking or code execution.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jqfp-m5f8-vg28, UBUNTU-CVE-2021-42220

## What is CVE-2021-42220?

CVE-2021-42220 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Dec 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A Cross Site Scripting (XSS) vulnerability exists in Dolibarr before 14.0.3 via the ticket creation flow. Exploitation requires that an admin copies the payload into a box.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-42220?

2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions | 14.0.3 |
| `dolibarr/dolibarr` | Packagist | All versions | 14.0.3 |

Products: Dolibarr Dolibarr.

## How do I fix CVE-2021-42220?

Upgrade dolibarr/dolibarr to 14.0.3 or later.

## Is CVE-2021-42220 being exploited?

There is no known exploitation of CVE-2021-42220 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-19212](https://insights.sbomify.com/CVE-2019-19212/): Dolibarr Cross-site Scripting via the qty parameter in product/fournisseurs.php (critical 9.8)
- [CVE-2018-16809](https://insights.sbomify.com/CVE-2018-16809/): Dolibarr SQL injection via the integer parameters qty and value_unit (critical 9.8)
- [CVE-2018-10094](https://insights.sbomify.com/CVE-2018-10094/): Dolibarr SQL injection vulnerability (critical 9.8)
- [CVE-2018-9019](https://insights.sbomify.com/CVE-2018-9019/): Dolibarr SQL Injection vulnerability (critical 9.8)
- [CVE-2017-14238](https://insights.sbomify.com/CVE-2017-14238/): Dolibarr SQL injection vulnerability in admin/menus/edit.php (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-42220 and fix it if it is affected.

What it is: CVE-2021-42220 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Dec 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-42220 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 14.0.3
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 14.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-42220/ (Markdown: https://insights.sbomify.com/CVE-2021-42220/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-42220
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-42220
- OSV: https://osv.dev/vulnerability/CVE-2021-42220

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-42220/
Summaries are generated and may contain mistakes; the official description above is the record.
