{"answers":{"affected":"6 open source packages ship an affected version, including github.com/go-yaml/yaml and gopkg.in/yaml.v2. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-4235 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2021-4235 is a medium-severity denial of service vulnerability in github.com/go-yaml/yaml, published on 27 Dec 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-4235 and fix it if it is affected.\n\nWhat it is: CVE-2021-4235 is a medium-severity denial of service vulnerability in github.com/go-yaml/yaml, published on 27 Dec 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-4235 exists.\n\nAffected packages and fixed versions:\n- github.com/go-yaml/yaml (Go): affected all versions; no fix listed\n- github.com/go-yaml/yaml (Go): affected all versions up to 2.1.0; no fix listed\n- github.com/go-yaml/yaml (Go): affected all versions up to 2.1.0; no fix listed\n- gopkg.in/yaml.v2 (Go): affected all versions; fixed in 2.2.3\n- gopkg.in/yaml.v2 (Go): affected all versions; fixed in 2.2.3\n- gopkg.in/yaml.v2 (Go): affected all versions; fixed in 2.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-4235/ (Markdown: https://insights.sbomify.com/CVE-2021-4235/index.md)","id":"CVE-2021-4235","markdown":"https://insights.sbomify.com/CVE-2021-4235/index.md","name":"CVE-2021-4235","record":{"aliases":["AZL-43447","AZL-43642","AZL-43918","AZL-44229","AZL-45237","AZL-45360","CLEANSTART-2026-ZL73481","DEBIAN-CVE-2021-4235","GHSA-r88r-gmrh-7j83","GO-2021-0061","UBUNTU-CVE-2021-4235"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Go YAML library","requires_auth":"none","summary":"Attackers can cause denial of service by providing crafted YAML input to applications using the vulnerable Go YAML library.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Go","cpe":[{"product":"yaml","vendor":"yaml_project"}],"cvss":{"score":5.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"Due to unbounded alias chasing, a maliciously crafted YAML file can cause the system to consume significant system resources. If parsing user input, this may be used as a denial of service vector.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of service in gopkg.in/yaml.v2","id":"CVE-2021-4235","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":6,"n_references":4,"next":{"headline":"Panic or authentication bypass in github.com/ecnepsnai/web","id":"CVE-2021-4236"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/go-yaml/yaml","purl":"pkg:golang/github.com/go-yaml/yaml","source":"GO-2021-0061"},{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":["2.1.0"],"package":"github.com/go-yaml/yaml","purl":null,"source":"GHSA-r88r-gmrh-7j83"},{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":["2.1.0"],"package":"github.com/go-yaml/yaml","purl":"pkg:golang/github.com/go-yaml/yaml","source":"GHSA-r88r-gmrh-7j83"},{"ecosystem":"Go","fixed":["2.2.3"],"introduced":["0"],"last_affected":[],"package":"gopkg.in/yaml.v2","purl":null,"source":"GHSA-r88r-gmrh-7j83"},{"ecosystem":"Go","fixed":["2.2.3"],"introduced":["0"],"last_affected":[],"package":"gopkg.in/yaml.v2","purl":"pkg:golang/gopkg.in/yaml.v2","source":"GHSA-r88r-gmrh-7j83"},{"ecosystem":"Go","fixed":["2.2.3"],"introduced":["0"],"last_affected":[],"package":"gopkg.in/yaml.v2","purl":"pkg:golang/gopkg.in/yaml.v2","source":"GO-2021-0061"}],"prev":{"headline":"Denial of service in OpenVPN Access Server","id":"CVE-2021-4234"},"products":["github.com/go-yaml/yaml","gopkg.in/yaml.v2"],"published":"2022-12-27","related":[{"cvss_score":7.5,"headline":"Uncaught Exception in eemeli/yaml","id":"CVE-2023-2251","kev_date_added":null,"published":"2023-04-24"},{"cvss_score":7.5,"headline":"Excessive resource consumption in gopkg.in/yaml.v2","id":"CVE-2022-3064","kev_date_added":null,"published":"2022-12-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-11","vendors":["github.com/go-yaml/yaml","gopkg.in/yaml.v2"]},"summary":"Attackers can cause denial of service by providing crafted YAML input to applications using the vulnerable Go YAML library.","url":"https://insights.sbomify.com/CVE-2021-4235/"}