# CVE-2021-42357: DOM based XSS Vulnerability in Apache Knox

> Attackers can execute malicious scripts or redirect users via crafted URLs in Apache Knox SSO, potentially leading to account takeover.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jan 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vv38-4xcj-q4rw

## What is CVE-2021-42357?

CVE-2021-42357 is a medium-severity cross-site scripting vulnerability in Apache Knox, published on 17 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

When using Apache Knox SSO prior to 1.6.1, a request could be crafted to redirect a user to a malicious page due to improper URL parsing. A request that included a specially crafted request parameter could be used to redirect the user to a page controlled by an attacker. This URL would need to be presented to the user outside the normal request flow through a XSS or phishing campaign.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-42357?

2 open source packages ship an affected version, including org.apache.knox:gateway-service-knoxsso. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.knox:gateway-service-knoxsso` | Maven | All versions | 1.6.1 |
| `org.apache.knox:gateway-service-knoxsso` | Maven | All versions | 1.6.1 |

Products: Apache Knox.

## How do I fix CVE-2021-42357?

Upgrade org.apache.knox:gateway-service-knoxsso to 1.6.1 or later.

## Is CVE-2021-42357 being exploited?

There is no known exploitation of CVE-2021-42357 in the wild and no public exploit code.

## Other vulnerabilities in Apache Knox

- [CVE-2017-5646](https://insights.sbomify.com/CVE-2017-5646/): Apache Knox allows impersonation of users (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-42357 and fix it if it is affected.

What it is: CVE-2021-42357 is a medium-severity cross-site scripting vulnerability in Apache Knox, published on 17 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-42357 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.knox:gateway-service-knoxsso (Maven): affected all versions; fixed in 1.6.1
- org.apache.knox:gateway-service-knoxsso (Maven): affected all versions; fixed in 1.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-42357/ (Markdown: https://insights.sbomify.com/CVE-2021-42357/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-42357
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-42357
- OSV: https://osv.dev/vulnerability/CVE-2021-42357

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-42357/
Summaries are generated and may contain mistakes; the official description above is the record.
