# CVE-2021-4236: Panic or authentication bypass in github.com/ecnepsnai/web

> Attackers can bypass authentication or cause a panic in WebSocket connections if an AuthenticateMethod hook is configured.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Dec 2022
- **Updated:** 11 Apr 2025
- **Also known as:** GHSA-5gjg-jgh4-gppm, GHSA-jpgg-cp2x-qrw3, GO-2021-0107

## What is CVE-2021-4236?

CVE-2021-4236 is a critical authentication bypass vulnerability in github.com/ecnepsnai/web, published on 27 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Web Sockets do not execute any AuthenticateMethod methods which may be set, leading to a nil pointer dereference if the returned UserData pointer is assumed to be non-nil, or authentication bypass. This issue only affects WebSockets with an AuthenticateMethod hook. Request handlers that do not explicitly use WebSockets are not vulnerable.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2021-4236?

5 open source packages ship an affected version, including github.com/ecnepsnai/web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ecnepsnai/web` | Go | From 1.4.0 | 1.5.2 |
| `github.com/ecnepsnai/web` | Go | From 1.4.0 | 1.5.2 |
| `github.com/ecnepsnai/web` | Go | From 1.4.0 | 1.5.2 |
| `github.com/ecnepsnai/web` | Go | From 1.4.0 | 1.5.2 |
| `github.com/ecnepsnai/web` | Go | From 1.4.0 | 1.5.2 |

Products: Web Project Web.

## How do I fix CVE-2021-4236?

Upgrade github.com/ecnepsnai/web to 1.5.2 or later.

## Is CVE-2021-4236 being exploited?

There is no known exploitation of CVE-2021-4236 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4236 and fix it if it is affected.

What it is: CVE-2021-4236 is a critical authentication bypass vulnerability in github.com/ecnepsnai/web, published on 27 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-4236 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ecnepsnai/web (Go): affected from 1.4.0; fixed in 1.5.2
- github.com/ecnepsnai/web (Go): affected from 1.4.0; fixed in 1.5.2
- github.com/ecnepsnai/web (Go): affected from 1.4.0; fixed in 1.5.2
- github.com/ecnepsnai/web (Go): affected from 1.4.0; fixed in 1.5.2
- github.com/ecnepsnai/web (Go): affected from 1.4.0; fixed in 1.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4236/ (Markdown: https://insights.sbomify.com/CVE-2021-4236/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4236
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4236
- OSV: https://osv.dev/vulnerability/CVE-2021-4236

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4236/
Summaries are generated and may contain mistakes; the official description above is the record.
