# CVE-2021-4241: phpservermon User.php setUserLoggedIn predictable algorithm in random number generator

> Attackers can predict session tokens due to a weak random number generator, potentially bypassing authentication in phpservermon.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Nov 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-hc4j-7mqg-cxjj

## What is CVE-2021-4241?

CVE-2021-4241 is a low-severity vulnerability in unspecified phpservermon, published on 15 Nov 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability, which was classified as problematic, was found in phpservermon. Affected is the function setUserLoggedIn of the file src/psm/Service/User.php. The manipulation leads to use of predictable algorithm in random number generator. The exploit has been disclosed to the public and may be used. The name of the patch is bb10a5f3c68527c58073258cb12446782d223bc3. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-213744.

Weakness: CWE-330 (Use of Insufficiently Random Values), CWE-331 (Insufficient Entropy)

## Which versions are affected by CVE-2021-4241?

2 open source packages ship an affected version, including phpservermon/phpservermon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpservermon/phpservermon` | Packagist | All versions | 3.6.0 |
| `phpservermon/phpservermon` | Packagist | All versions | 3.6.0 |

Products: Phpservermonitor Php Server Monitor.

## How do I fix CVE-2021-4241?

Upgrade phpservermon/phpservermon to 3.6.0 or later.

## Is CVE-2021-4241 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-4241 exists.

## Other vulnerabilities in unspecified phpservermon

- [CVE-2018-18921](https://insights.sbomify.com/CVE-2018-18921/): CSRF in PHP Server Monitor before 3.3.2 (medium 6.5)
- [CVE-2021-4097](https://insights.sbomify.com/CVE-2021-4097/): CRLF Injection in phpservermon/phpservermon (medium 6.3)
- [CVE-2021-4240](https://insights.sbomify.com/CVE-2021-4240/): phpservermon User.php generatePasswordResetToken predictable algorithm in random number generator (low 2.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4241 and fix it if it is affected.

What it is: CVE-2021-4241 is a low-severity vulnerability in unspecified phpservermon, published on 15 Nov 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-4241 exists.

Affected packages and fixed versions:
- phpservermon/phpservermon (Packagist): affected all versions; fixed in 3.6.0
- phpservermon/phpservermon (Packagist): affected all versions; fixed in 3.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4241/ (Markdown: https://insights.sbomify.com/CVE-2021-4241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4241
- OSV: https://osv.dev/vulnerability/CVE-2021-4241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4241/
Summaries are generated and may contain mistakes; the official description above is the record.
