CVE-2021-4244 yikes-inc-easy-mailchimp-extender Plugin add_field_to_form.php cross site scripting

Low 2.6 Published Updated

A cross-site scripting vulnerability in the Easy Mailchimp Extender plugin allows remote attackers to inject malicious scripts via manipulated form fields.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-4244?

CVE-2021-4244 is a low-severity cross-site scripting vulnerability in unspecified yikes-inc-easy-mailchimp-extender Plugin, published on 12 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability classified as problematic has been found in yikes-inc-easy-mailchimp-extender Plugin up to 6.8.5. This affects an unknown part of the file admin/partials/ajax/add_field_to_form.php. The manipulation of the argument field_name/merge_tag/field_type/list_id leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 6.8.6 is able to address this issue. The name of the patch is 3662c6593aa1bb4286781214891d26de2e947695. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215307.

Weakness: CWE-79, CWE-707

Which versions are affected by CVE-2021-4244?

2 open source packages ship an affected version, including yikesinc/yikes-inc-easy-mailchimp-extender. It affects 1 product.

PackageAffectedFixed in
yikesinc/yikes-inc-easy-mailchimp-extender PackagistAll versions6.8.6
yikesinc/yikes-inc-easy-mailchimp-extender PackagistAll versions6.8.6

Products include Yikesplugins Easy Forms for Mailchimp.

How do I fix CVE-2021-4244?

Upgrade yikesinc/yikes-inc-easy-mailchimp-extender to 6.8.6 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-4244 being exploited?

There is no known exploitation of CVE-2021-4244 in the wild and no public exploit code.

Sources

Also known as GHSA-837v-6vgx-jqcc.

Is CVE-2021-4244 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free