{"answers":{"affected":"2 open source packages ship an affected version, including yikesinc/yikes-inc-easy-mailchimp-extender. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-4244 in the wild and no public exploit code.","fix":"Upgrade yikesinc/yikes-inc-easy-mailchimp-extender to 6.8.6 or later.","what":"CVE-2021-4244 is a low-severity cross-site scripting vulnerability in unspecified yikes-inc-easy-mailchimp-extender Plugin, published on 12 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-4244 and fix it if it is affected.\n\nWhat it is: CVE-2021-4244 is a low-severity cross-site scripting vulnerability in unspecified yikes-inc-easy-mailchimp-extender Plugin, published on 12 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-4244 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yikesinc/yikes-inc-easy-mailchimp-extender (Packagist): affected all versions; fixed in 6.8.6\n- yikesinc/yikes-inc-easy-mailchimp-extender (Packagist): affected all versions; fixed in 6.8.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-4244/ (Markdown: https://insights.sbomify.com/CVE-2021-4244/index.md)","id":"CVE-2021-4244","markdown":"https://insights.sbomify.com/CVE-2021-4244/index.md","name":"CVE-2021-4244","record":{"aliases":["GHSA-837v-6vgx-jqcc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"A cross-site scripting vulnerability in the Easy Mailchimp Extender plugin allows remote attackers to inject malicious scripts via manipulated form fields.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"easy_forms_for_mailchimp","vendor":"yikesplugins"}],"cvss":{"score":2.6,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-707","name":"Improper Neutralization"}],"description":"A vulnerability classified as problematic has been found in yikes-inc-easy-mailchimp-extender Plugin up to 6.8.5. This affects an unknown part of the file admin/partials/ajax/add_field_to_form.php. The manipulation of the argument field_name/merge_tag/field_type/list_id leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 6.8.6 is able to address this issue. The name of the patch is 3662c6593aa1bb4286781214891d26de2e947695. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215307.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"yikes-inc-easy-mailchimp-extender Plugin add_field_to_form.php cross site scripting","id":"CVE-2021-4244","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"chbrown rfc6902 pointer.ts prototype pollution","id":"CVE-2021-4245"},"packages":[{"ecosystem":"Packagist","fixed":["6.8.6"],"introduced":["0"],"last_affected":[],"package":"yikesinc/yikes-inc-easy-mailchimp-extender","purl":null,"source":"GHSA-837v-6vgx-jqcc"},{"ecosystem":"Packagist","fixed":["6.8.6"],"introduced":["0"],"last_affected":[],"package":"yikesinc/yikes-inc-easy-mailchimp-extender","purl":"pkg:composer/yikesinc/yikes-inc-easy-mailchimp-extender","source":"GHSA-837v-6vgx-jqcc"}],"prev":{"headline":"Sapido BR270n/BRC76n/GR297/RB1732 syscmd.htm os command injection","id":"CVE-2021-4242"},"products":["yikes-inc-easy-mailchimp-extender Plugin"],"published":"2022-12-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["unspecified"]},"summary":"A cross-site scripting vulnerability in the Easy Mailchimp Extender plugin allows remote attackers to inject malicious scripts via manipulated form fields.","url":"https://insights.sbomify.com/CVE-2021-4244/"}